Bug 2070611 - [Errno 24] too many open files after some time syncing.
Summary: [Errno 24] too many open files after some time syncing.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Pulp
Version: 6.10.4
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: 6.12.0
Assignee: satellite6-bugs
QA Contact: Lai
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-03-31 14:15 UTC by Vedashree Deshpande
Modified: 2022-08-30 18:40 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-08-05 15:10:52 UTC
Target Upstream Version:


Attachments (Terms of Use)
open fd count - el8baseos sync pulp 3.14 without proxy (18.31 KB, text/plain)
2022-07-08 18:44 UTC, Daniel Alley
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github pulp pulp_rpm issues 2624 0 None closed Small FD leak during sync 2022-07-03 13:28:12 UTC
Red Hat Issue Tracker SAT-12598 0 None None None 2022-08-30 18:40:16 UTC
Red Hat Knowledge Base (Solution) 6970953 0 None None None 2022-08-05 14:38:45 UTC

Description Vedashree Deshpande 2022-03-31 14:15:39 UTC
Description of problem:
In satellite 6.10.4, while syncing any repository, 

the error getting is:

[Errno 24] too many open files  after some time syncing.


Version-Release number of selected component (if applicable):
6.10.4 although the customer says, he faces the issue in 6.9 as well as 6.10.3

Steps to Reproduce:
on Satellite 6.10.4 when syncing any repository. 


Actual results:
[Errno 24] too many open files  after some time syncing.

Expected results:
Repo should be synced. 

Additional info:
Customer did try to fix it with the workaround which helped. But needs a fix or a deeper investigation. 

~~~
checking the number of open files for the pulp user with
watch -n1 -t "lsof -u pulp -n | wc -l"

i reach over 4300 open files

which the pulp processes doent seem to be prepared to:
for i in $(ps waxu|grep ^pulp | awk '{print $2}') ; do prlimit --noheadings --pid $i --nofile; done
returns
1024:4096

manually setting it to a higher value with:
for i in $(ps waxu|grep ^pulp | awk '{print $2}') ; do prlimit --pid $i --nofile=4096:8192; done

~~~

Comment 3 Daniel Alley 2022-06-08 00:34:15 UTC
While running a sync of RHEL 7 I am seeing it cap out around 1020 open files.  I'm curious if this can still be produced on 6.10.6, and which repo specifically was being tested (I know it said "any" repo, but nonetheless)

We've fixed a few file leak bugs lately upstream, I believe at least some of those patches are already in 6.10.6.

Comment 20 pulp-infra@redhat.com 2022-07-03 13:28:13 UTC
The Pulp upstream bug status is at closed. Updating the external tracker on this bug.

Comment 21 pulp-infra@redhat.com 2022-07-03 13:28:16 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 22 Daniel Alley 2022-07-03 14:35:45 UTC
Setting it back to NEW because as I said I don't think the small bug makes any real difference.

Comment 23 pulp-infra@redhat.com 2022-07-03 15:21:35 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 25 Daniel Alley 2022-07-08 18:42:56 UTC
Brian,

I am unable to reproduce any issues without an http proxy in the loop, and combined with the two reports and the traceback we can probably conclude that it is a necessary component of the bug.

I now have some results (which are attached) from using this command to sync the repo https://cdn.redhat.com/content/dist/rhel8/8/x86_64/baseos/os/ with no HTTP proxy using the following command:

watch -t -n 10 "(date '+TIME:%H:%M:%S' ; lsof -a -u pulp -n -d ^mem -d ^cwd -d ^rtd -d ^txt -d ^DEL | wc -l) | tee -a /tmp/pulp_nofile_sync"

Could you get results of the same command running through the duration of the sync, syncing the same repository, under an HTTP proxy, so that we can compare them?file:///home/dalley/devel/pulp_nofile_sync

Comment 26 Daniel Alley 2022-07-08 18:44:55 UTC
Created attachment 1895482 [details]
open fd count - el8baseos sync pulp 3.14 without proxy

Comment 28 pulp-infra@redhat.com 2022-07-08 19:18:08 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 30 pulp-infra@redhat.com 2022-07-15 12:49:18 UTC
All upstream Pulp bugs are at MODIFIED+. Moving this bug to POST.

Comment 38 pulp-infra@redhat.com 2022-08-05 13:48:33 UTC
Requesting needsinfo from upstream developer dkliban, ggainey because the 'FailedQA' flag is set.


Note You need to log in before you can comment on or make changes to this bug.