RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2070639 - fapolicyd does not correctly handle SIGHUP
Summary: fapolicyd does not correctly handle SIGHUP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: fapolicyd
Version: 8.6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.7
Assignee: Radovan Sroka
QA Contact: Dalibor Pospíšil
Mirek Jahoda
URL:
Whiteboard:
: 2129185 (view as bug list)
Depends On:
Blocks: 2026666
TreeView+ depends on / blocked
 
Reported: 2022-03-31 15:47 UTC by Dalibor Pospíšil
Modified: 2022-11-08 10:53 UTC (History)
1 user (show)

Fixed In Version: fapolicyd-1.1.3-8.el8
Doc Type: Bug Fix
Doc Text:
.`fagenrules --load` now works correctly Previously, the `fapolicyd` service did not correctly handle the signal hang up (SIGHUP). Consequently, `fapolicyd` terminated after receiving the SIGHUP signal, and the `fagenrules --load` command did not work properly. This update contains a fix for the problem. As a result, `fagenrules --load` now works correctly, and rule updates no longer require manual restarts of `fapolicyd`.
Clone Of:
: 2070655 (view as bug list)
Environment:
Last Closed: 2022-11-08 09:51:54 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-117556 0 None None None 2022-03-31 15:51:41 UTC
Red Hat Issue Tracker SECENGSP-4480 0 None None None 2022-03-31 15:51:44 UTC
Red Hat Product Errata RHBA-2022:7627 0 None None None 2022-11-08 09:52:07 UTC

Description Dalibor Pospíšil 2022-03-31 15:47:34 UTC
Description of problem:
fapolicyd should reload the configuration, mainly the rules on SIGHUP 

Version-Release number of selected component (if applicable):
fapolicyd-1.0.2-6.el8

How reproducible:
100%

Steps to Reproduce:
1. systemctl start fapolicyd
2. systemctl kill -s HUP fapolicyd
3. systemctl status fapolicyd

Actual results:
# systemctl status fapolicyd
# echo $?
3


Expected results:
# systemctl status fapolicyd
# echo $?
0

Comment 17 Dalibor Pospíšil 2022-10-17 08:23:02 UTC
*** Bug 2129185 has been marked as a duplicate of this bug. ***

Comment 19 errata-xmlrpc 2022-11-08 09:51:54 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (fapolicyd bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7627


Note You need to log in before you can comment on or make changes to this bug.