Bug 207071 - long lines incorrectly handled by Apache's logresolve
Summary: long lines incorrectly handled by Apache's logresolve
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: httpd   
(Show other bugs)
Version: 4.4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
: ---
Assignee: Joe Orton
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-19 04:35 UTC by Nik Lam
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version: RHBA-2007-0209
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-01 22:55:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0209 normal SHIPPED_LIVE httpd bug fix update 2007-04-28 17:11:26 UTC
Apache Bugzilla 3459 None None None Never

Description Nik Lam 2006-09-19 04:35:07 UTC
Description of problem:
The logresolve ELF binary included in RHEL4 update 4 (and 3 these are the only
two versions I've tested) appear to incorrectly handle long lines in log files.

I think this is a very old bug which may have not been fixed because the Perl
script, logresolve.pl is commonly used instead of the C version of the
programme. However logresolve.pl doesn't appear to be part of Red Hat Enterprise
Linux.

Archived bug report - http://archive.apache.org/gnats/3459



Version-Release number of selected component (if applicable):
httpd-2.0.52-28


How reproducible:
Submit a log file containing lines longer than (i think) 1024 characters and
these lines will be split into at least two lines. 


Steps to Reproduce:
1. /usr/bin/logresolve < logfile.log > resolvedfile.log
2. /usr/bin/wc -l logfile.log
3. /usr/bin/wc -l resolvedlogfile.log


  
Actual results:
Will reveal that resolvedlogfile.log has more lines than logfile.log. A diff of
the files (with the hostnames/IP addresses excised) this will reveal the
additional/split lines.

Expected results:
There should be the same number of lines in the source and destination files.


Additional info:

Comment 1 Joe Orton 2006-12-14 15:40:37 UTC
We can bump the length of the line buffer used to 10K or something easily
enough; thanks for the report.

Comment 2 RHEL Product and Program Management 2006-12-14 15:44:25 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Red Hat Bugzilla 2007-05-01 22:55:47 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0209.html



Note You need to log in before you can comment on or make changes to this bug.