Bug 207075 - Typo in /etc/init.d/irqbalance makes irqbalance start at every runlevel change
Typo in /etc/init.d/irqbalance makes irqbalance start at every runlevel change
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: irqbalance (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 01:51 EDT by Philippe Troin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: 1.2-1.26
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 08:13:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Troin 2006-09-19 01:51:43 EDT
irqbalance-1.12-1.25

/etc/init.d/irqbalance says:

start() {
        echo -n $"Starting $prog: "
        daemon irqbalance $ONESHOT
        RETVAL=$?
        echo
        [ $RETVAL -eq 0 -a -n "$ONESHOT" ] && touch /var/lock/subsys/irqbalance
        return $RETVAL
}

If ONESHOT is empty, -n "$ONESHOT" is false, and /var/lock/subsys/irqbalance is
never touched.

This causes irqbalance to get started every time one changes the runlevel. 
Hopefully, only one irqbalance process runs, because the pid file is checked.
Nevertheless, it's broken.

It should be:

        [ $RETVAL -eq 0 -a -z "$ONESHOT" ] && touch /var/lock/subsys/irqbalance

Phil.
Comment 1 Neil Horman 2006-09-19 08:13:00 EDT
fixed in -1.26

Note You need to log in before you can comment on or make changes to this bug.