Bug 207081 - missing dependency on hplip
missing dependency on hplip
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
5
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 03:51 EDT by henri Michel
Modified: 2008-02-13 06:00 EST (History)
0 users

See Also:
Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 06:00:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description henri Michel 2006-09-19 03:51:49 EDT
Description of problem:
On a fresh fc5 system, updating hplip will trigger an update of hpijs
but will not trigger an update of cups-libs though it should
Because /usr/lib/python2.4/site-packages/cupsext.so refers to symbol
cupsLangDefault which is defined in updated cups-libs while it was not 
in original (not updated ) fc5 

Version-Release number of selected component (if applicable):
             |  fc5 original|           fc5 updated
-------------+--------------+-----------------------
hplip        |  0.9.8-6     |           1-6.6a-1.1
hpijs        |  0.9.8.6     |           1-6.6a-1.1
cups-libs    |  1.1.23-30.2 |           1.2.3-1.6


How reproducible:
always

Steps to Reproduce:
1.fresh fc5 install 
2.yum update hplip
3. /etc/init.d/hplip restart
4. (alternative)  hp-clean 
  
Actual results:
Traceback (most recent call last):
  File "/usr/bin/hp-clean", line 35, in ?
    from base import device, utils, maint
  File "/usr/share/hplip/base/device.py", line 39, in ?
    from prnt import pcl, ldl, cups
  File "/usr/share/hplip/prnt/cups.py", line 27, in ?
    import cupsext
ImportError: /usr/lib/python2.4/site-packages/cupsext.so: undefined symbol:
cupsLangDefault


Expected results:
should at least start !!! :-)

Additional info:
For original cups-libs (cups-libs-1.1.23-30.2.i386.rpm)
    $ ls -l /usr/lib/libcups.so.2
      -rwxr-xr-x 1 root root 132708 Feb 11  2006 /usr/lib/libcups.so.2
    $ readelf -s /usr/lib/libcups.so.2  | grep cupsLangDefault
    $ # no output
      
For updated cups-libs ( 178298 Sep 15 03:04 cups-libs-1.2.3-1.6.i386.rpm)
    $ ls -l /usr/lib/libcups.so.2
      -rwxr-xr-x 1 root root 218184 Sep 13 18:30 usr/lib/libcups.so.2
    $ readelf -s /usr/lib/libcups.so.2  | grep cupsLangDefault
      79: 0001dd80    69 FUNC    GLOBAL DEFAULT   10 cupsLangDefault
IMHO since updated libcups.so.2 exports 143 new global function symbols (almost
2x more) compared to the 156 of the original, it should get a different major
version number.
Comment 1 Tim Waugh 2006-12-15 11:38:54 EST
Fixed in CVS and will be pushed out with any future hplip update.

Note You need to log in before you can comment on or make changes to this bug.