Bug 207092 - dmraid -ay --ignorelocking
dmraid -ay --ignorelocking
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 06:43 EDT by Ronald Warsow
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version: 8.40-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-19 10:52:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ronald Warsow 2006-09-19 06:43:39 EDT
Description of problem:
the call in rc.sysinit at line ~270
"dmraid -ay --ignorelocking pdc_dhhjahccbf"
leads to the error message:
ERROR: No arguments allowed with -i

Version-Release number of selected component (if applicable):
i see this for month, but actually:
initscripts-8.31.5-1

How reproducible:
dmraid -ay --ignorelocking <any-name>
on systems with a non-active (via) raid controller

Steps to Reproduce:
1.key in: dmraid -ay --ignorelocking pdc_dhhjahccbf 
2.
3.
  
Actual results:
ERROR: No arguments allowed with -i

Expected results:
no errors.

Additional info:
this is a system with a non-active via raid controller.
Comment 1 Bill Nottingham 2006-09-19 10:52:11 EDT
This is fixed in rawhide.
Comment 2 Ronald Warsow 2006-09-20 10:57:38 EDT
maybe it's useful for other users which got the same problem.

my solution:

https://www.redhat.com/archives/fedora-list/2006-September/msg02311.html
Comment 3 Michal Jaegermann 2006-10-17 13:42:33 EDT
To add to comment #2: a simpler way, after you discovered with
'dmraid -r' that some devices have spurious RAID signatures (drives
were possibly "recycled", for example) is to do something like
'dmraid -r -E /dev/sdb' replacing, obviously, "/dev/sdb" with names
of devices so affected to erase signatures (metadata).

See also bug 176623 for another instance of troubles caused by
unexpected signatures.

Note You need to log in before you can comment on or make changes to this bug.