Bug 2071 - socks5 runsocks dumps core (LD_PRELOAD?)
Summary: socks5 runsocks dumps core (LD_PRELOAD?)
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-08 22:21 UTC by oran
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-04-12 17:10:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description oran 1999-04-08 22:21:48 UTC
It seems a fresh compilation of the latest socks5clients
(1.0r9) dumps core when runsocks is run. It seems the
problem lies with the dynamic loader, and not socks code
itself (well at least after stracing it seems so). With
various programs the point of error lies at different
points, but always during the loading of libraries.

runsocks is a simple wrapper which sets LD_PRELOAD and
LD_LIBRARY_PATH so that non-socks5-programs (e.g.
/usr/bin/telnet) can be socksified. It has it's own dynamic
lib which plays a bit with bind(), connect() etc. and I've
never had any sort of problem with it before.

This problem occured with glibc2.1.1-3 as well as some
earlier version. Since I made several upgrades (primarily
gnome-oriented) at the same time the problem may lie
elsewhere (although strace does lend the idea that it's
dieing while loading libraries).

Comment 1 Cristian Gafton 1999-04-12 17:10:59 UTC
I would guess this is more of a socks5 problem, that assumes that
glibc provides and will always a provide a certain interface for
internal functionality.


Note You need to log in before you can comment on or make changes to this bug.