Bug 207115 - GNU tar update to 1.15.91 breaks existing amanda installations
GNU tar update to 1.15.91 breaks existing amanda installations
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
5
All Linux
medium Severity high
: ---
: ---
Assigned To: Peter Vrabec
Ben Levenson
:
Depends On: 206979
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 10:45 EDT by Peter Vrabec
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version: tar-1.15.1-15.FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-03 04:56:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to copy tar snapshot files properly (4.81 KB, patch)
2006-09-27 13:43 EDT, Orion Poplawski
no flags Details | Diff

  None (edit)
Description Peter Vrabec 2006-09-19 10:45:36 EDT
+++ This bug was initially created as a clone of Bug #206979 +++

Description of problem:

The GNU tar update to 1.15.91 a few days ago has broken my amanda backup system
due to a switch to a different state file format. Specifically, from analysis of
/var/log/amanda/ the problem is when sending sizes of level 1s (or above):
sendsize[9076]: time 0.799: /bin/tar: Unexpected field value in snapshot file
sendsize[9076]: time 0.799: /bin/tar: Error is not recoverable: exiting now
sendsize[9076]: time 0.800: .....
sendsize[9076]: estimate time for /home level 1: 0.004
sendsize[9076]: no size line match in /bin/tar output for "/home"

From some searching, this is a known issue and caused the amanda people to issue
2.5.1 incorporating some sort of change to work around it:
http://groups.yahoo.com/group/amanda-hackers/message/5149

However the real problem is in tar - it should not casually introduce a new file
format breaking existing incremental dump state files.

Either way, amanda backups using tar are non-functional on FC5 after this update.

Version-Release number of selected component (if applicable):

1.15.91

How reproducible:

Requires incremental backup state files generated with an older tar.

-- Additional comment from pvrabec@redhat.com on 2006-09-18 14:14 EST --
Jay, is it possible to upgrade amanda and solve this problem this way?

-- Additional comment from fenlason@redhat.com on 2006-09-18 14:32 EST --
Amanda 2.5.1 (the one that's been fixed to work with the newer tar) was 
released after FC6T3 froze, so it's not going into FC6.  It's significantly 
configuration-incompatible with 2.5.0p2, too, so pushing it as an update in 
FC5 would break all existing Amanda installations, not just ones that use 
gnutar as their dumper. 
 
I can look in to how much effort it'll take to backport the newer gnutar 
support from 2.5.1 to 2.5.0p2, but why oh why did you push a tar update that 
broke existing installations? 

-- Additional comment from rvokal@redhat.com on 2006-09-19 04:01 EST --
Heads up, this affects RHEL5

-- Additional comment from pvrabec@redhat.com on 2006-09-19 05:26 EST --
I have pushed new tar-1.15.91 update, because incremental backup in tar-1.15.90 didn't work 
properly (#206121).

tar-1.15.91 was also pushed into RHEL-5 and FC-6, so we really need to solve this problem 
fast.  Backporting the newer gnutar support from 2.5.1 to 2.5.0p2 seems to be best way. If it's 
not possible, we can either downgrade tar to version 1.15.1, which includes backporting some 
patches or start talking about amanda upgarade.


-- Additional comment from jturner@redhat.com on 2006-09-19 10:20 EST --
Deferring QE ack until we have a solid proposal for how to address this problem.
Comment 1 Orion Poplawski 2006-09-27 12:23:33 EDT
Just a comment - I've been trying to get amanda 2.5.1 running to work around
this issue and have already run into 2 critical bugs.  Amanda 2.5.1 is nowhere
near ready for prime time.

However, maybe the changes to support tar 1.15.2 can be backported to amanda
2.5.0p2.  I think all they involved was making amanda treat the tar snapshot
files as opaque files and not making assumptions about their content.  Haven't
looked at the code yet though...
Comment 2 Orion Poplawski 2006-09-27 13:43:42 EDT
Created attachment 137231 [details]
patch to copy tar snapshot files properly

Here is a backported to 2.5.0p2 patch of the change made on July 14 2006 in
amanda CVS to copy the snapshot files.	Untested.
Comment 3 Peter Vrabec 2006-10-03 04:56:13 EDT
problem fixed with tar-1.15.1-15.FC5

Note You need to log in before you can comment on or make changes to this bug.