Bug 2071250 - [abrt] fedora-third-party: get_flatpak_remotes(): repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
Summary: [abrt] fedora-third-party: get_flatpak_remotes(): repository.py:74:get_flatpa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-third-party
Version: 36
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:65b4f6e35106f969b040ad883ec...
: 2071471 2073976 2075421 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-02 11:53 UTC by Ryan Prinze
Modified: 2022-04-20 23:29 UTC (History)
4 users (show)

Fixed In Version: fedora-third-party-0.10-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-04-20 23:29:35 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (2.30 KB, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details
File: cpuinfo (2.67 KB, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details
File: environ (1.26 KB, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details
File: mountinfo (3.05 KB, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details
File: namespaces (172 bytes, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details
File: open_fds (320 bytes, text/plain)
2022-04-02 11:53 UTC, Ryan Prinze
no flags Details

Description Ryan Prinze 2022-04-02 11:53:44 UTC
Description of problem:
I opened Gnome Software Center, then Software Repositories. I received the error "fedora-third-party Misbehavior"

Version-Release number of selected component:
fedora-third-party-0.9.1-1.fc36

Additional info:
reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gnome.Software-3209.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)

Traceback (most recent call last):
  File "/usr/bin/fedora-third-party", line 33, in <module>
    sys.exit(load_entry_point('fedora-third-party==0.9.1', 'console_scripts', 'fedora-third-party')())
  File "/usr/lib/python3.10/site-packages/click/core.py", line 1128, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/click/core.py", line 1053, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python3.10/site-packages/click/core.py", line 1659, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python3.10/site-packages/click/core.py", line 1395, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python3.10/site-packages/click/core.py", line 754, in invoke
    return __callback(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/click/decorators.py", line 84, in new_func
    return ctx.invoke(f, obj, *args, **kwargs)
  File "/usr/lib/python3.10/site-packages/click/core.py", line 754, in invoke
    return __callback(*args, **kwargs)
  File "/usr/lib/python3.10/site-packages/fedora_third_party/cli.py", line 104, in list
    repositories = [r for r in cfg.list_repositories() if not r.is_hidden()]
  File "/usr/lib/python3.10/site-packages/fedora_third_party/cli.py", line 104, in <listcomp>
    repositories = [r for r in cfg.list_repositories() if not r.is_hidden()]
  File "/usr/lib/python3.10/site-packages/fedora_third_party/repository.py", line 97, in is_hidden
    remote = self.get_existing_remote()
  File "/usr/lib/python3.10/site-packages/fedora_third_party/repository.py", line 93, in get_existing_remote
    return next((r for r in get_flatpak_remotes() if r.name == self.name), None)
  File "/usr/lib/python3.10/site-packages/fedora_third_party/repository.py", line 74, in get_flatpak_remotes
    name, filter, options = line.split("\t")
ValueError: not enough values to unpack (expected 3, got 2)

Local variables in innermost frame:
output: 'fedora\t-\toci\nfedora-testing\t-\tdisabled,oci\nflathub\t-\n'
result: [FlatpakRemote(name='fedora', filter=None, disabled=False), FlatpakRemote(name='fedora-testing', filter=None, disabled=True)]
line: 'flathub\t-'
name: 'fedora-testing'
filter: None
options: 'disabled,oci'

Comment 1 Ryan Prinze 2022-04-02 11:53:47 UTC
Created attachment 1870122 [details]
File: backtrace

Comment 2 Ryan Prinze 2022-04-02 11:53:48 UTC
Created attachment 1870123 [details]
File: cpuinfo

Comment 3 Ryan Prinze 2022-04-02 11:53:49 UTC
Created attachment 1870124 [details]
File: environ

Comment 4 Ryan Prinze 2022-04-02 11:53:50 UTC
Created attachment 1870125 [details]
File: mountinfo

Comment 5 Ryan Prinze 2022-04-02 11:53:50 UTC
Created attachment 1870126 [details]
File: namespaces

Comment 6 Ryan Prinze 2022-04-02 11:53:51 UTC
Created attachment 1870127 [details]
File: open_fds

Comment 7 DACBARBOS Brand 2022-04-04 00:36:40 UTC
*** Bug 2071471 has been marked as a duplicate of this bug. ***

Comment 8 Thomas Citharel 2022-04-04 09:06:58 UTC
Similar problem has been detected:

Opening Gnome-Software repository list settings.

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-flatpak-com.discordapp.Discord-2385.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.2-3.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
package:        fedora-third-party-0.9.1-1.fc36
reason:         repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 9 Lukas Ruzicka 2022-04-04 12:46:15 UTC
Similar problem has been detected:

I was trying to search for applications through Software when this happened.

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gnome.Software-2653.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
package:        fedora-third-party-0.9.1-1.fc36
reason:         repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 10 raul.nanclares 2022-04-05 21:04:46 UTC
Similar problem has been detected:

Trying to get updates from Gnome software

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gnome.Software-4397.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
package:        fedora-third-party-0.9.1-1.fc36
reason:         repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 11 Owen Taylor 2022-04-06 15:57:10 UTC
Will do an update with a fix for this soon.

Comment 12 Fedora Update System 2022-04-07 04:32:25 UTC
FEDORA-2022-1ed936a3ac has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-1ed936a3ac

Comment 13 David Linder 2022-04-07 10:52:05 UTC
Similar problem has been detected:

open gnome-software
open softwaresources

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gnome.Software-2486.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
package:        fedora-third-party-0.9.1-1.fc36
reason:         repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 14 Fedora Update System 2022-04-07 18:01:23 UTC
FEDORA-2022-1ed936a3ac has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-1ed936a3ac`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-1ed936a3ac

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 15 vesdia+bugzilla 2022-04-08 15:56:03 UTC
Similar problem has been detected:

Installed flathub repository and then went to check my list of repositories and I got this error.

reporter:       libreport-2.17.1
cgroup:         0::/user.slice/user-1000.slice/user/app.slice/app-gnome-org.gnome.Software-17468.scope
cmdline:        /usr/bin/python3 /usr/bin/fedora-third-party list --csv --columns=type,name
crash_function: get_flatpak_remotes
exception_type: ValueError
executable:     /usr/bin/fedora-third-party
interpreter:    python3-3.10.4-1.fc36.x86_64
kernel:         5.17.1-300.fc36.x86_64
package:        fedora-third-party-0.9.1-1.fc36
reason:         repository.py:74:get_flatpak_remotes:ValueError: not enough values to unpack (expected 3, got 2)
runlevel:       N 5
type:           Python3
uid:            1000

Comment 16 alex 2022-04-11 09:10:53 UTC
*** Bug 2073976 has been marked as a duplicate of this bug. ***

Comment 17 alex 2022-04-14 08:00:24 UTC
*** Bug 2075421 has been marked as a duplicate of this bug. ***

Comment 18 Fedora Update System 2022-04-20 23:29:35 UTC
FEDORA-2022-1ed936a3ac has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.