Bug 2071437 - postgresql-server should depend on util-linux
Summary: postgresql-server should depend on util-linux
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: 36
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Ondřej Sloup
QA Contact: Fedora Extras Quality Assurance
Depends On:
TreeView+ depends on / blocked
Reported: 2022-04-03 20:04 UTC by Daniel Mach
Modified: 2022-11-30 13:52 UTC (History)
10 users (show)

Fixed In Version: postgresql-15.0-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2022-09-07 09:27:25 UTC
Type: Bug

Attachments (Terms of Use)

Description Daniel Mach 2022-04-03 20:04:58 UTC
Description of problem:
postgresql-server should depend on util-linux, otherwise postgresql-setup fails on missing 'runuser'

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. install postgresql-server in a container (minimal install, no weak deps etc.)
2. /usr/bin/postgresql-setup --initdb

Actual results:
/usr/bin/postgresql-setup: line 17: /usr/sbin/runuser: No such file or directory

Expected results:
the command works

Comment 1 Ondřej Sloup 2022-08-01 10:11:56 UTC
In what container did you reproduce the issue? I could not reproduce it, and it would be a great help if you could point me in the right direction.
I've tried it on a new fedora installation, and it worked. Did you have any arguments while installing the PostgreSQL?

Comment 2 Ondřej Sloup 2022-08-03 14:31:51 UTC
Reproduced in podman:

$ podman run -it fedora 
$ dnf install postgresql-server
$ /usr/bin/postgresql-setup --initdb
/usr/bin/postgresql-setup: line 17: /usr/sbin/runuser: No such file or directory

Comment 3 Ondřej Sloup 2022-08-03 16:10:44 UTC
Fixed in the pull request:

Comment 4 Fedora Update System 2022-11-30 13:46:15 UTC
FEDORA-2022-6853500e7e has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2022-6853500e7e

Comment 5 Fedora Update System 2022-11-30 13:52:19 UTC
FEDORA-2022-6853500e7e has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.