Bug 2071553
| Summary: | LEAPP upgrade fails to run installer due to insufficient resources | |||
|---|---|---|---|---|
| Product: | Red Hat Enterprise Linux 7 | Reporter: | Evgeni Golov <egolov> | |
| Component: | leapp-repository | Assignee: | Leapp team <leapp-notifications> | |
| Status: | CLOSED ERRATA | QA Contact: | Lukas Pramuk <lpramuk> | |
| Severity: | high | Docs Contact: | ||
| Priority: | unspecified | |||
| Version: | 7.9 | CC: | ahumbe, ehelms, jbhatia, lpramuk, mhecko, pstodulk | |
| Target Milestone: | rc | Keywords: | OtherQA, Triaged | |
| Target Release: | --- | Flags: | pm-rhel:
mirror+
|
|
| Hardware: | Unspecified | |||
| OS: | Unspecified | |||
| Whiteboard: | ||||
| Fixed In Version: | leapp-repository-0.17.0-1.el7_9 | Doc Type: | If docs needed, set a value | |
| Doc Text: | Story Points: | --- | ||
| Clone Of: | ||||
| : | 2092122 (view as bug list) | Environment: | ||
| Last Closed: | 2022-11-09 12:33:16 UTC | Type: | Bug | |
| Regression: | --- | Mount Type: | --- | |
| Documentation: | --- | CRM: | ||
| Verified Versions: | Category: | --- | ||
| oVirt Team: | --- | RHEL 7.3 requirements from Atomic Host: | ||
| Cloudforms Team: | --- | Target Upstream Version: | ||
| Embargoed: | ||||
| Bug Depends On: | ||||
| Bug Blocks: | 2092122 | |||
|
Description
Evgeni Golov
2022-04-04 08:06:34 UTC
I've verified that my patch fixes the issue described, but it needs to be applied *before* the whole upgrade procedure begins and can't fix an "aborted" upgrade. However, the trivial workaround for the issue is to just run `foreman-installer --disable-system-checks` (no further parameters required) after the EL8 system has booted and the logs indicate that the installer has not been run correctly. As such, I don't think this should be "sev: high" :) The upstream PR has been merged:
https://github.com/oamg/leapp-repository/pull/875
VERIFIED. @Satellite 6.11.2 leapp-0.15.0-2.el7_9.noarch leapp-upgrade-el7toel8-0.17.0-1.el7_9.noarch by the following manual reproducer: 1) Have a machine with ~ 7GB RAM with Satellite 6.11.2 el7 installed # satellite-installer 2022-09-14 07:34:22 [NOTICE] [root] Loading installer configuration. This will take some time. 2022-09-14 07:34:29 [NOTICE] [root] Running installer with log based terminal output at level NOTICE. 2022-09-14 07:34:29 [NOTICE] [root] Use -l to set the terminal output log level to ERROR, WARN, NOTICE, INFO, or DEBUG. See --full-help for definitions. Insufficient memory for tuning size Tuning profile 'default' requires at least 8 GB of memory and 1 CPU cores >>> installer refuses to run without override flag (--disable-system-checks) 2) LEAPP upgrade to RHEL8 # leapp upgrade --reboot 3) Check Satellite health after LEAPP finished # hammer ping Status: ok Server Response: Duration: 0ms candlepin: Status: ok Server Response: Duration: 46ms candlepin_auth: Status: ok Server Response: Duration: 44ms candlepin_events: Status: ok message: 0 Processed, 0 Failed Server Response: Duration: 0ms katello_events: Status: ok message: 0 Processed, 0 Failed Server Response: Duration: 1ms pulp3: Status: ok Server Response: Duration: 85ms pulp3_content: Status: ok Server Response: Duration: 80ms foreman_tasks: Status: ok Server Response: Duration: 5ms >>> during upgrade process installer has been run successfully using override flag (--disable-system-checks) Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (leapp and leapp-repository bug fix and enhancement update), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHBA-2022:7895 |