Bug 207160 - 3ware Raid Controller fails to load on install
3ware Raid Controller fails to load on install
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Peter Martuccelli
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-19 15:18 EDT by David A. Cafaro
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-26 13:42:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David A. Cafaro 2006-09-19 15:18:56 EDT
Description of problem:

When installing on a AMD Opteron 265 (Single CPU dual Core) system the 3Ware
Raid controller is not recognized.  Some information on the system:

Single AMD Dual Core 265 Series Processor
Tyan s2895 Tunder K8WE Motherboard
- nForce Pro 2200/2050/AMD 8131 Chipset
3Ware 9500SX 4 Port RAID SATA controller w/4 250GB Drives in RAID5 mode
NVidia SATA on board controller w/1 500GB 

On Install Boot, the system begins loading the 3w-9xxx module, checking the boot
log I see the following errors:

<4>3w-9xxx: scsi0: AEN: ERROR (0x04:0x0025): Cache flush failed; some data lost:
port=32, address=0x6C020.

(this is repeated multiple times with different adddres= values. Then, )

<4>3w-9xxx: scsi0: ERROR: (0x06:0x0022): AEN drain failed during reset sequence.
<4>3w-9xxx: scsi0: ERROR: (0x06:0x001F): Microcontroller not readying during reset
<6>ACPI: PIC interrrupt for device 0000:0a:04.0 disabled

At this ping the libata and sata_nv drives load, detect the drive and continue
on with out problem.

Eventually I get to the installer partition screen where only the 500GB drive
connected to the onboard SATA_NV drive is available to install as /dev/sda

Version-Release number of selected component (if applicable):
All stock packages that came with RHEL 5 Server Beta 1

How reproducible:
Every install attempt

Steps to Reproduce:
1. Boot the installer disks with simialer configured machine.
2. Hit enter at the boot prompt to start installation and answer the standard
questions
3. Watch as the 3ware controller drives fail to show in the partition options

On soft reboot (ctrl-alt-del) I get a kernel dump with information like this:

Call Trace:
[<ffffffff882953c5>] :3w_9xxx:twa_shutdown+0x17/0x1a
...more stuff about pcie_device shutdown, device_shutdown,
kernal_restart_prepare, etc...

RIP [<ffffffff88292806>] :3w_9xxx:__twa_shutdown+0xc/0xce
 RSP <ffff81013fcc7dc8>
CR2: 00000000000006d8
 <0>Kernel panic - not syncing: Attempted to kill init!

Actual results:
Failes to recognize RAID5 array on 3ware controller

Expected results:
Option to parition and use RAD5 array on 3ware controller

Additional Information:
Fedora Core 5 was able to install with out issues.
Comment 1 David A. Cafaro 2006-09-19 16:35:47 EDT
Some updated information.  I disabled the onbaord NVidia SATA controllers and
now I do not get the above error messages.  Instead after the 3ware drivers load
and reports back the /dev/sda device (the RAID5 device) I get the floowing messages:

<5>sd 0:0:0:0: Attached scsi disk sda
<7>PM: Adding info for the No Bus:target0:0:1
<7>PM: Removing info for the No Bus:target0:0:1

(this is reapeated sequentailly through, )

<7>PM: Removing info for No Bus:target0:0:15
<7>libata version 2.00 loaded.

This failed on the first boot attempt I tried with the on board SATA devices
disabled.  I was eventaully told it had no valid HardDrives to install to.  I
then rebooted to get a better look at the error message and on this boot the
drives were recognized (the onboard nvidia controller still being disabled).  I
didn't get a good look at the original failed boot error message, but I do
remember seeing simialer to the above listed ones, just with no working HD
instead of the now working ones.

I will continue to test different setups, as well as see how far the install goes.
Comment 2 David A. Cafaro 2006-09-26 11:11:13 EDT
Ok, after installing with the nv_sata controller disable via bios, I was able to
get the system fully installed.

I then reenabled the nv_sata controller in bios as was able to get both the
3ware controller and the nvidia onboard controller to work perfectly in the
running system.  I then rebooted to try a reinstall, and now all drives are
recognized by the installer.  

I have no clue what the issue might or might not have been.  Sorry, this appears
to have been a wasted bug filing.  If I run into the same problem again on
installation I'll reopen this bug.  At this time, I can only guess that there
was some kind of temporary interupt conflict or something simialerly weird.
Comment 3 Peter Martuccelli 2006-09-26 13:42:12 EDT
I will close this entry out as not a bug, if the problem comes back in beta2 or
GA please reopen the bugzilla.  

Note You need to log in before you can comment on or make changes to this bug.