Bug 207162 - predetermine/change RHN Satellite kickstart scripts exec order
predetermine/change RHN Satellite kickstart scripts exec order
Status: CLOSED DUPLICATE of bug 215711
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McCune
Brandon Perkins
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2006-09-19 15:23 EDT by christoph doerbeck
Modified: 2007-10-29 21:58 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-01-18 01:23:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description christoph doerbeck 2006-09-19 15:23:38 EDT
RHN Sat 4.1.0

Several RHN Sat customers have created several single-function scripts to do
tradidtional kickstart pre and post work.  However, they need the ability to
(re)order the execution queue.  Deleting all the scripts and reinserting them is
not an acceptable long term solution.

As a bonus * it would also be handy if previsouly created scripts could be
reused in other kickstart profiles.  IE: if I created a swell script to do
dynamic partitioning (which I have done), I'd like to simply give it a name and
then reuse it in several kickstart profiles.  Thus, if it has a bug fix or
feature enhancement, I could update all kickstarts at one time with one edit :-)

Last bonus * it would also be great if user could determine when the rhnreg_ks
step occurs.  At the moment, if kickstart scripts need to exec before rhnks_reg,
they MUST be pre-scripts which is not always feasible/clean/intuitive.
Comment 1 christoph doerbeck 2006-09-19 15:32:28 EDT
Sorry, in section titled "Last Bonus" - I meant to say that if a script is to
execute before rhnreg_ks, then it MUST be a %post nochroot script.  
Comment 2 christoph doerbeck 2006-09-19 15:47:26 EDT
scratch the request for reuse of kickstart profiles.  I opened a separate
ticket/request (https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=207168)
Comment 3 Máirín Duffy 2007-01-09 13:49:03 EST

*** This bug has been marked as a duplicate of 207168 ***
Comment 4 Máirín Duffy 2007-01-09 13:54:07 EST
disregard the dupe message in comment #3, my goof; i misread comment #2.
Comment 5 Mike McCune 2007-01-18 01:23:14 EST

*** This bug has been marked as a duplicate of 215711 ***

Note You need to log in before you can comment on or make changes to this bug.