Bug 207227 - Xen0 reboot command can not reboot Tiger4 machine.
Summary: Xen0 reboot command can not reboot Tiger4 machine.
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xen   
(Show other bugs)
Version: 6
Hardware: ia64 Linux
medium
medium
Target Milestone: ---
Assignee: Xen Maintainance List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-20 02:27 UTC by You, Yongkang
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: 2.6.18-1.2784.fc6xen
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-20 12:31:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xen0 serial console output when execution reboot. (2.80 KB, text/plain)
2006-09-20 02:27 UTC, You, Yongkang
no flags Details

Description You, Yongkang 2006-09-20 02:27:34 UTC
Description of problem:

FC6 test3 Xen can boot up successfully. 
But reboot command couldn't reboot machine.
Machine will do shutdown, but at last it will stop at "Restarting System" and
refuse to do the reboot. 

Before "Restarting System" line, there was a bug reported from iosapic.c . I
will paste the serial console output to the attachment.

Version-Release number of selected component (if applicable):


How reproducible:
Every time.

Steps to Reproduce:
1. Boot FC6 test3 with Xen and Xen0 kernel.
2. Execute reboot command in it.

  
Actual results:
Machine won't reboot with reboot command.


Expected results:
Machine can reboot.

Additional info:

Comment 1 You, Yongkang 2006-09-20 02:27:34 UTC
Created attachment 136698 [details]
Xen0 serial console output when execution reboot.

Comment 2 Aron Griffis 2006-09-21 14:40:10 UTC
This is a duplicate of bug 203032

Comment 3 Akio Takebe 2006-10-16 07:36:11 UTC
This problem is caused by debugger_trap_immediate() in dom0_shutdown().
2.6.18-1.2784.fc6xen don't have it in dom0_shutdown().
So this problem is fixed.

I confirmed that dom0 could reboot by using 2.6.18-1.2784.fc6xen.

Best Regards,

Akio Takebe 

Comment 4 You, Yongkang 2006-10-17 01:40:21 UTC
Yes. I can reboot Rawhide Xen too. :)

Comment 5 Brian Stein 2006-10-19 13:42:24 UTC
Can this be closed or are there add'l outstanding issues?

Comment 6 You, Yongkang 2006-10-20 00:51:48 UTC
Yes. It can be closed. 
Can I change the bug status to FIXED?
Or let other people do this action?

Comment 7 Brian Stein 2006-10-20 12:31:35 UTC
Thanks for the update. Closing.



Note You need to log in before you can comment on or make changes to this bug.