Bug 207237 - rc.sysinit passes wrong flag to hostname command on startup
rc.sysinit passes wrong flag to hostname command on startup
Status: CLOSED DUPLICATE of bug 200683
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 00:25 EDT by Keith G. Robertson-Turner
Modified: 2014-03-16 23:02 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 00:54:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Keith G. Robertson-Turner 2006-09-20 00:25:05 EDT
Description of problem:

Setting hostname thereisnospoon:  [  OK  ]
ERROR: No arguments allowed with -i

Version-Release number of selected component (if applicable):
initscripts-8.31.5-1

How reproducible:
Always

Steps to Reproduce:
1. Boot system
2.
3.
  
Actual results:
Although the hostname is set correctly, the "ERROR: No arguments allowed with
-i" error is printed.

Expected results:
Correct flag should be used, and no error message should result.

Additional info:
I've looked at rc.sysinit, which verifies as unmodified on my system, and I can
see no reason for this. The relevant call is...

###
# Set the hostname.
update_boot_stage RChostname
action $"Setting hostname ${HOSTNAME}: " hostname ${HOSTNAME}
###

Is see no mention of an "-i" switch there, so really I have no idea where this
is coming from.
Comment 1 Bill Nottingham 2006-09-20 00:54:37 EDT
Heh, that's not hostname, it's later in the script.

*** This bug has been marked as a duplicate of 200683 ***

Note You need to log in before you can comment on or make changes to this bug.