Bug 207239 - rpmbuild -ta broken by recent tar
rpmbuild -ta broken by recent tar
Status: CLOSED DUPLICATE of bug 206841
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 01:19 EDT by Mike Pope
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-20 03:27:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Annotated strace output (7.76 KB, text/plain)
2006-09-20 01:19 EDT, Mike Pope
no flags Details

  None (edit)
Description Mike Pope 2006-09-20 01:19:05 EDT
Description of problem:
rpmbuild -ta has stopped working, since tar-1.15.91.1.FC5.  Downgrading to 
tar-1.15.90-2.FC5 fixes the problem.  The more recent tar whines about 
rpmbuild execing it with the *.spec argument, and the message confuses 
rpmbuild.  See the attached summarized strace output.

Version-Release number of selected component (if applicable):
rpm-build-4.4.2.15.2 (meta-buglet: bugzilla does not list rpm-build in the 
Component menu)

How reproducible:
rpmbuild -ta <known-working-tarball>

Actual results:
error: Name field must be present in package: (main package)
...etc,etc

Expected results:
.rpm built as usual.

Additional info:
Comment 1 Mike Pope 2006-09-20 01:19:05 EDT
Created attachment 136704 [details]
Annotated strace output
Comment 2 Nalin Dahyabhai 2006-09-20 01:28:19 EDT
Looks like a duplicate of bug #206841.
Comment 3 Paul Nasrat 2006-09-20 03:27:07 EDT
Workaround for now is TAR_OPTIONS=--wildcards discussion is occuring on
rpm-devel list about the correct way to fix.

*** This bug has been marked as a duplicate of 206841 ***

Note You need to log in before you can comment on or make changes to this bug.