Bug 207285 - Evolution emits SELinux error messages to terminal and fails to talk to NetworkManager
Summary: Evolution emits SELinux error messages to terminal and fails to talk to Netwo...
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-20 14:22 UTC by Dave Malcolm
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 00:05:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2006-09-20 14:22:21 UTC
Description of problem:
Starting evolution from the terminal, this message appears on startup, and
repeats every few seconds:
libnm_glib_dbus_init: error, org.freedesktop.DBus.Error.AccessDenied raised:
 An SELinux policy prevents this sender from sending this message to this
recipient (rejected message had interface "org.freedesktop.DBus" member "Hello"
error name "(unset)" destination "org.freedesktop.DBus")

This is with default SELinux settings i.e. targetted policy, with enforcing on.
 I believe everything is properly labelled.

Version-Release number of selected component (if applicable):
evolution-2.8.0-3.fc6
NetworkManager-0.6.4-5.fc6
dbus-0.92-1.fc6


How reproducible:
100%

Additional info:
"ps axZ" shows evolution is running in "user_u:system_r:unconfined_t"
and that NetworkManager is running in "system_u:system_r:initrc_t"

Looks similar to bug 207221

Comment 1 Dave Malcolm 2006-09-21 18:16:09 UTC
Turns out I didn't have selinux-policy-targeted installed.

Now installed, and fs relabelled.  
Will retry on next reboot.

Sorry for the noise

Comment 2 Matthew Barnes 2006-09-21 18:46:08 UTC
For what it's worth, I haven't been seeing those messages and NetworkManager is
running in "system_u:system_r:NetworkManager_t" on my machine.  But I know next
to nothing about SELinux.

Comment 3 Dave Malcolm 2006-09-22 00:05:41 UTC
Somehow I didn't have selinux-policy-targeted installed.
Upon installing, relabelling the filesystem, and rebooting, NetworkManager is
now in the correct domain (as in comment #2), and the evolution messages go away.

Resolving NOTABUG


Note You need to log in before you can comment on or make changes to this bug.