Bug 2073 - RFE: Some well-known addresses should be allowed in CC field.
RFE: Some well-known addresses should be allowed in CC field.
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.18
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: PnT DevOps Devs
http://bugzilla.mozilla.org/show_bug....
: FutureFeature, Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-08 21:07 EDT by Aleksey Nogin
Modified: 2013-06-23 23:11 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 16:04:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 19057 None None None Never

  None (edit)
Description Aleksey Nogin 1999-04-08 21:07:47 EDT
Right now Bugzilla seems to be to strict and disallows any
e-mail address in the CC field that is not registered with
Bugzilla. However, it would be nice to be able to put some
well-known bug report addresses for the products (such as
bugs-make@gnu.org when reporting a bug in make).
Comment 1 Anonymous 1999-04-22 16:03:59 EDT
That's a reasonable request, I'll implement it.

- Alex
Comment 2 Aleksey Nogin 2001-08-06 16:28:49 EDT
This stayed "DEFERRED" for over 2 years - shows why "DEFERRED" is not such a
good idea.
Comment 3 David Lawrence 2001-08-06 16:55:49 EDT
You are correct that DEFERRED is not a good idea. I will bring up discussion
with my peers to see if a better solution is available. In the meantime, I
apologize that this has not been looked at for a while. Basically the cc
information for each bug report is stored in a table where the cc id is the
userid of the registered user is keyed to a bug id number. For this reason when
someone enters a Cc address it has to be a valid bugzilla user. There is a way
to override and have Bugzilla actually create a new account for the address
entered if they do not have a userid already. But this has been debated as to
whether people should be able to enter addresses at will without the user's
permission.
Comment 4 Aleksey Nogin 2002-11-13 06:38:10 EST
See also http://bugzilla.mozilla.org/show_bug.cgi?id=19057
Comment 5 Arenas Belon, Carlo Marcelo 2003-04-08 11:21:58 EDT
at least internal support mail addresses should be added as valid IMHO.  i just
had to report a likelly bug (#88270) on rhn-applet, and CC applet@rhn.redhat.com
as recommended by the message i received from the product, sadly it was not
possible because the mail was not valid and therefore i had to resend the data
on a mail (which would need additional tracking internally on Red Hat alongside
of the same report on bugzilla)
Comment 6 Arenas Belon, Carlo Marcelo 2003-04-08 11:26:43 EDT
this problem was still visible on bugzilla version 2.17.1
Comment 7 David Lawrence 2006-04-08 14:13:52 EDT
Red Hat's current Bugzilla version is 2.18. I am moving all older open bugs to
this version. Any bugs against the older versions will need to be verified that
they are still bugs. This will help me also to sort them better.
Comment 8 Aleksey Nogin 2006-04-08 15:14:05 EDT
Still an issue in 2.18. Although with "external references" option it is
probably less important now than when I've first filed this (exactly 7 years ago!).
Comment 9 Red Hat Bugzilla 2007-02-05 14:35:00 EST
REOPENED status has been deprecated. ASSIGNED with keyword of Reopened is preferred.
Comment 10 David Lawrence 2007-08-17 16:04:34 EDT
Closing WONTFIX as this is a design issue with Bugzilla. The cc table stores the
mapping based on userid from a profiles table. Which means it has to have a
entry in the profiles table to map to, hence must be a valid account. This is
unlikely to change as it would require numerous changes in other code as well.

Note You need to log in before you can comment on or make changes to this bug.