Bug 2073208 - sagemath does not launch
Summary: sagemath does not launch
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sagemath
Version: 36
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paulo Andrade
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-07 21:43 UTC by Miguel Zilhao
Modified: 2022-06-16 01:20 UTC (History)
1 user (show)

Fixed In Version: sagemath-9.6-1.fc37 sagemath-9.6-1.fc36
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-06-07 17:43:12 UTC
Type: Bug


Attachments (Terms of Use)

Description Miguel Zilhao 2022-04-07 21:43:20 UTC
Description of problem: sagemath crashes immediately and cannot be launched from the terminal


Version-Release number of selected component (if applicable): 9.5


How reproducible: Always


Steps to Reproduce:
1. sudo dnf -y install sagemath
2. sage

Actual results:

┌────────────────────────────────────────────────────────────────────┐
│ SageMath version 9.5, Release Date: 2022-01-30                     │
│ Using Python 3.10.4. Type "help()" for help.                       │
└────────────────────────────────────────────────────────────────────┘
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib64/python3.10/pathlib.py", line 1303, in is_dir
    return S_ISDIR(self.stat().st_mode)
AttributeError: 'str' object has no attribute 'stat'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib64/sagemath/local/bin/sage-ipython", line 15, in <module>
    app.initialize()
  File "/usr/lib/python3.10/site-packages/traitlets/config/application.py", line 88, in inner
    return method(app, *args, **kwargs)
  File "/usr/lib/python3.10/site-packages/IPython/terminal/ipapp.py", line 276, in initialize
    self.init_shell()
  File "/usr/lib64/python3.10/site-packages/sage/repl/interpreter.py", line 789, in init_shell
    self.shell.extension_manager.load_extension(SAGE_EXTENSION)
  File "/usr/lib/python3.10/site-packages/IPython/core/extensions.py", line 76, in load_extension
    return self._load_extension(module_str)
  File "/usr/lib/python3.10/site-packages/IPython/core/extensions.py", line 99, in _load_extension
    if self._call_load_ipython_extension(mod):
  File "/usr/lib/python3.10/site-packages/IPython/core/extensions.py", line 151, in _call_load_ipython_extension
    mod.load_ipython_extension(self.shell)
  File "/usr/lib64/python3.10/site-packages/sage/repl/__init__.py", line 5, in load_ipython_extension
    sage.repl.ipython_extension.load_ipython_extension(*args)
  File "/usr/lib64/python3.10/site-packages/sage/repl/ipython_extension.py", line 617, in wrapper
    result = func(*args, **kwargs)
  File "/usr/lib64/python3.10/site-packages/sage/repl/ipython_extension.py", line 630, in load_ipython_extension
    SageCustomizations(shell=ip)
  File "/usr/lib64/python3.10/site-packages/sage/repl/ipython_extension.py", line 434, in __init__
    import sage.all # until sage's import hell is fixed
  File "/usr/lib64/python3.10/site-packages/sage/all.py", line 131, in <module>
    from sage.rings.all      import *
  File "/usr/lib64/python3.10/site-packages/sage/rings/all.py", line 87, in <module>
    from .qqbar import (AlgebraicRealField, AA,
  File "/usr/lib64/python3.10/site-packages/sage/rings/qqbar.py", line 2810, in <module>
    QQxy = QQ['x', 'y']
  File "sage/structure/parent.pyx", line 1276, in sage.structure.parent.Parent.__getitem__
  File "/usr/lib64/python3.10/site-packages/sage/categories/rings.py", line 1177, in __getitem__
    return PolynomialRing(self, elts)
  File "/usr/lib64/python3.10/site-packages/sage/rings/polynomial/polynomial_ring_constructor.py", line 647, in PolynomialRing
    return _multi_variate(base_ring, names, **kwds)
  File "/usr/lib64/python3.10/site-packages/sage/rings/polynomial/polynomial_ring_constructor.py", line 775, in _multi_variate
    from sage.rings.polynomial.multi_polynomial_libsingular import MPolynomialRing_libsingular
  File "sage/rings/polynomial/multi_polynomial_libsingular.pyx", line 1, in init sage.rings.polynomial.multi_polynomial_libsingular
  File "sage/libs/singular/singular.pyx", line 1558, in init sage.libs.singular.singular
  File "sage/libs/singular/singular.pyx", line 1532, in sage.libs.singular.singular.init_libsingular
ImportError: cannot load Singular library from libSingular.so (b'libSingular.so: cannot open shared object file: No such file or directory')



Expected results: Expected to start the sage interpreter.


Additional info:

At least one of the problems seems to be the missing libSingular library, which was present until Fedora 35 but cannot be found in the current (36) repositories: https://pkgs.org/download/Singular-devel

Comment 1 Miguel Zilhao 2022-04-07 21:52:23 UTC
Actually, libSingular can be installed in 36 as well, and then sage launches just fine. So maybe it's just a matter of adding Singular-devel to the sagemath dependencies.

Comment 2 Fedora Update System 2022-06-07 17:38:50 UTC
FEDORA-2022-3193745ede has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2022-3193745ede

Comment 3 Fedora Update System 2022-06-07 17:43:12 UTC
FEDORA-2022-3193745ede has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Fedora Update System 2022-06-07 21:39:58 UTC
FEDORA-2022-0326bd55bf has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

Comment 5 Fedora Update System 2022-06-08 01:14:21 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-0326bd55bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-0326bd55bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 6 Fedora Update System 2022-06-16 01:20:28 UTC
FEDORA-2022-0326bd55bf has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.