Bug 207369 - gaim-otr is not usable as installed from extras with gaim2
gaim-otr is not usable as installed from extras with gaim2
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gaim-otr (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-20 16:46 EDT by Mitchell Lewandowski
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 18:37:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mitchell Lewandowski 2006-09-20 16:46:56 EDT
Description of problem:
The gaim-otr package is not usable when installing FC6 Test3 (the plugin is
greyed out in the plugins window from within Gaim).

Version-Release number of selected component (if applicable):
gaim-2.0.0-0.11.beta3.fc6
gaim-otr-3.0.0-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. yum -y install gaim-otr
2. Restart gaim
3. Click Tools->Plugins from the Buddy List
4. Scroll down to see Off-the-Record Messaging not available for use
  
Actual results:
Users are not able to use the gaim-otr plugin.

Expected results:
Users should be able to use encryption with their IM services through this plugin.

Additional info:
It appears that with gaim2, you need to apply the following patch to the
gaim-otr source:
http://www.cypherpunks.ca/otr/gaim2b2-otr.diff
Comment 1 Paul Wouters 2006-09-21 10:55:10 EDT
Yes, this is a known bug. Unfortunate, I cannot fix it right now.

I tried installing FC6test2 and failed horribly. Building the package in mock
for Fedora Extras on the redhat build systems fails. No configure script is
generated. 

I am trying to resolve this issue, but it might have to wait until I have
managed to get an FC6 install working, or root access to someone's FC6 box/xenu
image. If you have one, or can give me access to one, let me know.
Comment 2 Paul Wouters 2006-09-21 10:56:47 EDT
Try building this one on your machine:
ftp://ftp.xelerance.com/gaim-otr-3.0.0-0.2.20060920bcvs.src.rpm
Comment 3 Mitchell Lewandowski 2006-09-21 12:12:54 EDT
The spec never finds the configure script that autoconf makes, but adding
another cd to the spec seems to work fine:

$ diff -urwN gaim-otr.spec gaim-otr-configure-working.spec 
--- gaim-otr.spec       2006-09-20 10:55:39.000000000 -0400
+++ gaim-otr-configure-working.spec     2006-09-21 12:09:07.000000000 -0400
@@ -30,6 +30,7 @@
 #autoreconf
 %build
 
+cd %{name}
 %configure 
 make %{?_smp_mflags} all
 
The configure fails though, presumably complaining about gtk, but I have the
-devel versions installed (may be an upstream issue, not sure):
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for EXTRA... no
configure: error: glib
./configure: line 19168: exit: gtk: numeric argument required
./configure: line 19168: exit: gtk: numeric argument required
error: Bad exit status from /home/mitchl/build/tmp/rpm-tmp.95063 (%build)

Here are my gtk/glib versions:
$ rpm -q gtk2-devel glib2-devel
gtk2-devel-2.10.3-6.fc6
glib2-devel-2.12.3-2.fc6

Any other info I can give you, let me know.
Comment 4 Paul Wouters 2006-09-21 13:17:40 EDT
Ahhhh. So the extra cd command fixes the problem for me. Thanks for that one.
not sure why it is needed, must be because of the cvs versioning and the
prep/build macros.

The next error is that a gaim file is missing. I just found out that gaim now
has a gaim-devel package containing the missing file, so I added the
BuildRequire: gaim-devel >= 2.0.0

I've fired off a new build request, so hopefully the package will be done soon.

Note You need to log in before you can comment on or make changes to this bug.