Bug 207390 - Unable to open drm device in i965
Summary: Unable to open drm device in i965
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-20 21:57 UTC by German Monroy
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-28 21:00:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg log (58.29 KB, application/octet-stream)
2006-09-20 22:00 UTC, German Monroy
no flags Details
lspci output (1.45 KB, application/octet-stream)
2006-09-20 22:01 UTC, German Monroy
no flags Details
dmesg output (24.93 KB, application/octet-stream)
2006-09-20 22:02 UTC, German Monroy
no flags Details
Functional sources (91.60 KB, application/x-compressed)
2006-09-20 22:05 UTC, German Monroy
no flags Details

Description German Monroy 2006-09-20 21:57:02 UTC
Description of problem:
 When starting X dri gets disabled because X is unable to open i915.  Xorg.0.log
reports:
     drmOpenByBusid: Searching for BusID pci:0000:00:02.0
     drmOpenDevice: node name is /dev/dri/card0
     drmOpenDevice: open result is -1, (No such device)
     drmOpenDevice: open result is -1, (No such device)


Version-Release number of selected component (if applicable):
FC6-Test3

How reproducible:
always

Steps to Reproduce:
1. Install FC6Test3 in a Q965/G965/G946 (broadwater) system
2. start x
3.
  
Actual results:
Direct Rendering gets disabled (failed)

Expected results:
Direct rendering should be enabled

Additional info:
Same distro (moving the hdd) works ok in a 945 chipset

Comment 1 German Monroy 2006-09-20 22:00:39 UTC
Created attachment 136787 [details]
Xorg log

Comment 2 German Monroy 2006-09-20 22:01:30 UTC
Created attachment 136788 [details]
lspci output

Comment 3 German Monroy 2006-09-20 22:02:37 UTC
Created attachment 136789 [details]
dmesg output

Comment 4 German Monroy 2006-09-20 22:05:59 UTC
Created attachment 136790 [details]
Functional sources

Recompiling just the drm and i915 modules with the attached files fixes the
problem.

Comment 5 German Monroy 2006-09-28 21:03:44 UTC
Oops, never mind :-(

I was reading the changelog for a newer kernel than the one I was running.  The
kernel in FC6 Test3 did not have the changes required for Broadwater support
(linux-2.6-drm-i965.patch).  

I just tested 2.6.18-1.2699.fc6 and the 3D module loads i915 fine.

I am sorry for the confusion.


Note You need to log in before you can comment on or make changes to this bug.