Bug 207443 - Call Trace thrown on screen when network is restarted on bonding
Call Trace thrown on screen when network is restarted on bonding
Status: CLOSED DUPLICATE of bug 210577
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Robert Hentosh
Brian Brock
:
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-09-21 01:15 EDT by Giribabu Bikki
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-23 15:15:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Giribabu Bikki 2006-09-21 01:15:59 EDT
Description of problem:When bonding is started on RHEL5 Beta1, Call traces are
thrown on the screen. But the bond works fine. The failover also happens
successfully. This is seen on mode=1 and mode=6.


Version-Release number of selected component (if applicable):RHEL5-b1


How reproducible:evrytime network restart with bonding


Steps to Reproduce:
1.Install RHEL5 B1
2.Create the Bond with mode=6
3.Restart the network services.
4.Call trace are thrown on the screen.
  
Actual results:call traces are thrown on the screen


Expected results:no call traces are expected on the console


Additional info:
Comment 1 RHEL Product and Program Management 2006-10-12 10:02:45 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux release.  Product Management has requested further review
of this request by Red Hat Engineering.  This request is not yet committed for
inclusion in release.
Comment 3 jordan hargrave 2006-10-19 10:56:20 EDT
The bonding drivers will need to run their monitoring threads to run in 
sleepable context.  The way to do this is by using workqueues.  However, all 
spinlocks/read/write locks that may be called by the monitoring threads must 
be changed to use the _bh forms.
Comment 4 John W. Linville 2006-10-23 15:15:13 EDT

*** This bug has been marked as a duplicate of 210577 ***

Note You need to log in before you can comment on or make changes to this bug.