Bug 207478 - fc6 t3 - monodevelop fails to launch
fc6 t3 - monodevelop fails to launch
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: monodevelop (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul F. Johnson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 08:13 EDT by das_deniz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 15:50:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
first failure log - prompts to continue after this failure but that fails too. (1.95 KB, text/plain)
2006-09-21 08:13 EDT, das_deniz
no flags Details

  None (edit)
Description das_deniz 2006-09-21 08:13:23 EDT
Description of problem:

yum install monodevelop (only default fc6t3 yum repositories)
yum all updates as of 21-SEP 8am EDT
try to launch Applications -> Programming -> MonoDevelop
errors and prompts to quit or continue - continue is fatal.

Version-Release number of selected component (if applicable):

mono-web-1.1.17.1-1.fc6
mono-winforms-1.1.17.1-1.fc6
mono-data-sqlite-1.1.17.1-1.fc6
mono-data-oracle-1.1.17.1-1.fc6
mono-data-postgresql-1.1.17.1-1.fc6
mono-data-1.1.17.1-1.fc6
monodevelop-0.12-3.fc6
mono-data-sybase-1.1.17.1-1.fc6
mono-core-1.1.17.1-1.fc6
monodoc-1.1.17-4.fc6

How reproducible:

every launch attempt

Steps to Reproduce:
1. install mono and monodevelop
2. try to launch
3. fails
  
Actual results:

fails

Expected results:

works

Additional info:

will attatch failure log.
Comment 1 das_deniz 2006-09-21 08:13:23 EDT
Created attachment 136848 [details]
first failure log - prompts to continue after this failure but that fails too.
Comment 3 Alexander Larsson 2006-09-25 04:56:36 EDT
This is a monodevelop (in extras) problem, not a mono issue.
It looks like a requirement or a build-requirement error.
Maybe it needs to buildrequire mono-nunit-devel or require mono-nunit.
Comment 4 Paul F. Johnson 2006-09-25 12:08:16 EDT
Which processor are you using (it does make a difference)?

Also, could you try this

cd ~/.config
rm -rf MonoDevelop

and then from a terminal window try and run monodevelop. Quite a lot of the
time, the MonoDevelop directory in the config directory gets hosed and needs a
clean out.

I can't reproduce the bug here, it is possible as alex says though that I need
to rebuild with mono-nunit as a require (do you have it installed?)
Comment 5 das_deniz 2006-09-25 14:49:37 EDT
32bit x68

$ cd ~/.config
$ rm -rf MonoDevelop/
$ cd
$ monodevelop &

dies as before without mono-nunit installed

rpm -qv mono-nunit
package mono-nunit is not installed

after running 'yum -y install mono-nunit' launches fine.
Comment 6 Paul F. Johnson 2006-09-25 15:50:10 EDT
Thanks. Fixed on the next spin. 

Note You need to log in before you can comment on or make changes to this bug.