Bug 207482 - system-config-cluster does not reload cluster.conf when incomplete
system-config-cluster does not reload cluster.conf when incomplete
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: system-config-cluster (Show other bugs)
5.0
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 08:28 EDT by Jerome Delamarche
Modified: 2009-04-16 18:33 EDT (History)
1 user (show)

See Also:
Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-07 19:14:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jerome Delamarche 2006-09-21 08:28:48 EDT
Description of problem:

The system-config-cluster tool may generate a cluster.conf file which is
syntactically correct (from the XML point-overview), but which it cannot reload.

Version-Release number of selected component (if applicable):
system-config-cluster 1.0.27

How reproducible:

easyly

Steps to Reproduce:
1.declare a GFS resource corresponding to a filesystem that still does not exist
2.save the file
3.reload it using system-config-cluster
  
Actual results:

Relax-NG validity error : Extra element rm in interleave
/root/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/root/cluster.conf fails to validate

Expected results:

no error, but you can click OK to continue, it will succeed.

Additional info:

The problem is caused by the missing "fsid" attribute of a "<fs>" resource.
Since the filesystem did not exist, no fsid has been found.

Workaround:
add an empty attribute in the cluster.conf file:
<fs .... fsid="" .... />
Comment 3 Jim Parsons 2007-01-10 13:12:37 EST
This required alot of consistency fixes between the schema file and the UI,
which I believe are all addressed now - so I am marking this ticket modified as
of build 1.0.36-1.0
Comment 4 RHEL Product and Program Management 2007-02-07 19:14:15 EST
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.
Comment 5 Nate Straz 2007-12-13 12:29:31 EST
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.

Note You need to log in before you can comment on or make changes to this bug.