Bug 2075 - rdistd not found in /usr/nbin
rdistd not found in /usr/nbin
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: rdist (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
: 2154 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-04-08 21:12 EDT by v.kuhlmann
Modified: 2015-03-04 20:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-03 13:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description v.kuhlmann 1999-04-08 21:12:53 EDT
rdist fails to update a remote host with the error "rdistd:
command not found"
reason: rdistd is installed in /usr/sbin, which is not in
the default search path (for tcsh anyway, and the sbin's are
not generally in user's search paths)
Fix: ln -s ../sbin/rdistd /usr/bin

Volker
Comment 1 Jeff Johnson 1999-04-09 14:45:59 EDT
Add /usr/sbin to your path if root uses /bin/tcsh or a user wishes
to use rdist.
Comment 2 Jeff Johnson 1999-06-03 13:49:59 EDT
*** Bug 2154 has been marked as a duplicate of this bug. ***

 Because rdistd is in /usr/sbin, which is not in the normal
path, normal people attempting to rdist to a RedHat 5.1
system will fail with an error message like:
	targethost: LOCAL ERROR: Unexpected input from server: "sh:
rdistd: command not found". In order for
rdist'ing to something to work, rdistd must be on the
normal search path that 'rsh foo command' gets one.

 I see two cures:
1) relocate rdistd to something that is on the normal
   search path for rsh (eg to /usr/bin).
2) add (via PAM or just defaults) /usr/sbin to the PATH
   that rshd gives to children.

 Until either happens, rdist is sort of broken.

 Please note that not all shells support running dotfiles
on non-interactive (eg rsh'ing in) situations. I think
that rdist should a) work 'out of the box' on a RedHat
machine and b) even for people with such shells, so I
don't consider a suggestion of 'change your .cshrc or
whatever to add /usr/sbin' to be much of a solution.

(I'm aware that this is a duplicate of another person's
bug, but I want to complain about the situation not being
resolved, and one can't reopen someone else's bug report
to do that.)


------- Additional Comments From pbrown@redhat.com  04/13/99 12:27 -------
Jeff, we really have to fix this one.

------- Additional Comments From jbj@redhat.com  04/13/99 14:43 -------
The argument that "rdist is mostly broken" doesn't hold water because
"normal people" still have to setup their .rhosts to permit access.
Setting the PATH environment variable is part of the process of
permitting remote access that needs to be performed by the user,
not Red Hat.

Adding /usr/sbin to the PATH variable in a file read during
non-interactive, non-login (i.e. rsh) access (i.e. ~/.bashrc for bash)
permits rdist to work.

For bash, add to ~/.bashrc
	PATH="$PATH:/usr/sbin"

For tcsh (and csh), add to ~/.cshrc
	setenv PATH "${PATH}:/usr/sbin"

Otherwise, create a symlink from /usr/sbin/rdistd to someplace
within the path, as in
	ln -sf /usr/sbin/rdistd /usr/bin/rdistd

I'll take a look at adding the /usr/bin/rdistd symlink in the rdist
package, but the fix probably won't be in Red Hat 6.0. Thanks for this
(and your many other) reports.Fixed in rdist-6.1.5-7.

Note You need to log in before you can comment on or make changes to this bug.