Bug 207603 - /etc/issue replaced without notification when redhat-release is up2dated
/etc/issue replaced without notification when redhat-release is up2dated
Status: CLOSED DUPLICATE of bug 162154
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: redhat-release (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 16:04 EDT by William Temple
Modified: 2007-11-16 20:14 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-10 11:18:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William Temple 2006-09-21 16:04:32 EDT
Description of problem:
When up2date'ing a system, customized /etc/issue is replaced with RH default.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Customize /etc/issue
2. up2date /etc/redhat-release
3.
  
Actual results:
/etc/issue is replaced with RH default from package

Expected results:
/etc/issue to be preserved (optimal result in a perfect world) or otherwise
notify sys admin that this file is going to be removed/replaced or otherwise
edited. Other packages save conf files as .rpmsave, .rpmnew, .rpmorig.  It is
clearly displayed during package install/upgrade/removal when using the rpm
command or up2date.

Additional info:
this is somewhat of a nuisance and it defeats corporate standards / legal
disclaimers.  Also, publicly revealing your OS version and level without
authentication / interactive login is not the best for security.
Comment 1 Tim Powers 2006-09-22 10:06:08 EDT
The specfile has /etc/issue and /etc/issue.net set at:

  %config(noreplace) %attr(0644,root,root) /etc/issue
  %config(noreplace) %attr(0644,root,root) /etc/issue.net

Are you sure that you customized the correct file? The settings above mean that it should have saved your 
custom files in place and should have installed the new issue files with the .rpmnew extension.
Comment 2 William Temple 2006-09-25 16:10:15 EDT
Affirmative on customizing the correct file. It appears as though it is not 
doing an upgrade but a removal of old package then installation of new one.  If 
it helps, we are updating RHEL4 U2 --> RHEL4 U4.  Here are the new files I find 
after running the update.  issue.rpmsave is my customized file.

[root@<server_name> etc]# ls -alh|grep issue
-rw-r--r--   1 root root    76 Jul 18 20:38 issue
-rw-r--r--   1 root root   411 May 18 09:53 issue.backup
-rw-r--r--   1 root root    75 Jul 18 20:38 issue.net
lrwxrwxrwx   1 root root    10 Aug 22 10:49 issue.net.rpmsave -> /etc/issue
-rwxr-xr-x   1 root root   794 Aug 22 10:49 issue.rpmsave

Here is a snippet of text of output displayed from up2date
Installing /var/spool/up2date/glibc-headers-2.3.4-2.25.i386.rpm...
Installing /var/spool/up2date/glibc-devel-2.3.4-2.25.i386.rpm...
Installing /var/spool/up2date/gcc-3.4.6-3.i386.rpm...
Installing /var/spool/up2date/gcc-c++-3.4.6-3.i386.rpm...
Installing /var/spool/up2date/redhat-release-4AS-5.5.i386.rpm...
warning: /etc/issue created as /etc/issue.rpmnew
warning: /etc/issue.net created as /etc/issue.net.rpmnew
Installing /var/spool/up2date/iputils-20020927-18.EL4.3.i386.rpm...
Installing /var/spool/up2date/seamonkey-nss-1.0.5-0.1.el4.i386.rpm...
Installing /var/spool/up2date/audit-1.0.14-1.EL4.i386.rpm...
Installing /var/spool/up2date/numactl-0.6.4-1.28.i386.rpm...
Comment 3 William Temple 2006-10-04 23:51:00 EDT
[root@<server> ~]# ls -alh /etc/issue*
-rwxr-xr-x  1 root root 793 Aug  8 15:15 /etc/issue
lrwxrwxrwx  1 root root  10 Aug  8 15:15 /etc/issue.net -> /etc/issue
-rw-r--r--  1 root root 417 Aug  8 15:15 /etc/issue.sec.1.0-29.151524


After rhn_check (scheduled updates on internal satellite server) and reboot.  
Note: my /etc/issue and issue.net files are now overwritten at this point.  
the .rpmsave files have my customized text.

[root@<server> ~]# ls -alh /etc/issue*
-rw-r--r--  1 root root  76 Jul 18 20:38 /etc/issue
-rw-r--r--  1 root root  75 Jul 18 20:38 /etc/issue.net
lrwxrwxrwx  1 root root  10 Aug  8 15:15 /etc/issue.net.rpmsave -> /etc/issue
-rwxr-xr-x  1 root root 793 Aug  8 15:15 /etc/issue.rpmsave
-rw-r--r--  1 root root 417 Aug  8 15:15 /etc/issue.sec.1.0-29.151524
Comment 4 Mike McLean 2006-10-10 11:18:09 EDT
This bug was fixed in U3. However, for the fix to work you have to start with a
fixed version of redhat-release. Since you were going from U2 to U4 you were
bitten by the triggers that existed in the old U2 package. See #162154 for
background.

Now that you have a fixed package installed, your next upgrade should behave the
way you expect.

*** This bug has been marked as a duplicate of 162154 ***

Note You need to log in before you can comment on or make changes to this bug.