Bug 207609 - qemu-dm logfile name should be based on VM name, instead of PID
qemu-dm logfile name should be based on VM name, instead of PID
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 16:50 EDT by Daniel Berrange
Modified: 2008-03-19 20:33 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-19 20:33:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Use name instead of PID (2.86 KB, patch)
2007-05-31 20:56 EDT, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Daniel Berrange 2006-09-21 16:50:48 EDT
Description of problem:
Every HVM guest run spawns a qemu-dm process to manage the device model. This
process saves logs into a file /var/log/xen/qemu-dm-<PID>.log. There are two
problems with this. Firfst there is an unbounded number of log files created &
never cleaned, a minor point. More importantly & the point of this ticket, is
that there's no way to correlate the log file back to the domain being run.

If a HVM guest crashes or otherwise misbehaves it would be desirable to capture
the qemu-dm logfile, however, there's no easy way find out which for many log
files corresponds to the domain being run. This problem would be trivially
solved if the log file was named based on the guest name, rather than PID of the
qemu-dm process. This would also cut down on the number of log files created,
since the same log would be used each time a domain was booted.

Version-Release number of selected component (if applicable):
xen-3.0.2-33

How reproducible:
Always

Steps to Reproduce:
1. Create an HVM guest called 'demo'
2.
3.
  
Actual results:
Log file is /var/log/xen/qemu-dm-<some random PID number>.log

Expected results:
Log file is /var/log/xen/qemu-dm-demo.log

Additional info:
The logfile naming scheme appears to be set in the file tools/ioemu/vl.c
Comment 1 Daniel Berrange 2007-05-31 20:56:32 EDT
Created attachment 155854 [details]
Use name instead of PID

This patch is against xen-unstable.hg shortly after xen-3.1.0
Comment 2 Red Hat Bugzilla 2007-07-24 19:58:57 EDT
change QA contact

Note You need to log in before you can comment on or make changes to this bug.