Bug 207613 - gnash-plugin: bad dependency on webclient
gnash-plugin: bad dependency on webclient
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnash (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Patrice Dumas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 17:32 EDT by Ville Skyttä
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7.1-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-24 04:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2006-09-21 17:32:05 EDT
gnash-plugin has a dependency on "webclient" which is incorrect for two reasons:
- The dependency is satisfied by all web browsers, including ones that can not
  use Mozilla plugins, for example w3m-el in FE.
- The dependency on webclient does not guarantee proper dir ownership.

Fix: replace "Requires: webclient" with "Requires: %{_libdir}/mozilla/plugins"

See bug 131247 for more info.
Comment 1 Patrice Dumas 2006-09-22 03:28:26 EDT
Indeed requiring webclinet is bad, you're right.
Requiring %{_libdir}/mozilla/plugins isn't right either, because
this is satisfied by kdebase, although gnash-plugin doesn't
work with konqueror (while gnash-klash do). For an unknown
reason konqueror (kdebase) doesn't provide webclient. If it
isn't a bug, maybe the right thing for gnash-plugin would
be to

Requires: %{_libdir}/mozilla/plugins webclient

Ideas?
Comment 2 Ville Skyttä 2006-09-22 18:16:28 EDT
(In reply to comment #1)
> Requires: %{_libdir}/mozilla/plugins webclient

That would be satisfied if one has let's say kdebase and w3m-el installed (no
mozilla/seamonkey/firefox) which is not quite correct either, but at least it
would fix the dir ownership part of the problem and not cause new ones.

Even though kdebase not providing webclient at the moment sounds like an
oversight to me, I don't have better suggestions right now than your Requires:
idea above.
Comment 3 Patrice Dumas 2006-09-24 04:52:06 EDT
Ok, fixed in 0.7.1-8, with comments indicating that it is
still an issue.

Note You need to log in before you can comment on or make changes to this bug.