Bug 207626 - Eclipse will not start in fc6t3
Eclipse will not start in fc6t3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i686 Linux
medium Severity urgent
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-21 19:48 EDT by Dan Brady
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 3.2.0-7.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-22 14:01:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of Error (571.07 KB, image/png)
2006-09-21 19:48 EDT, Dan Brady
no flags Details

  None (edit)
Description Dan Brady 2006-09-21 19:48:08 EDT
Description of problem: Everytime i try to run the program, it almost finishes,
but an error pops up and stops eclipse from running


Version-Release number of selected component (if applicable):
2.6.17-1.2630.fc6

How reproducible: every time.


Steps to Reproduce:
1.Start eclipse either from the command prompt or from kmenu
2.
3.
  
Actual results:
Error

Expected results:
Application Running


Additional info:
Error that happens:
JVM terminated. Exit code=127
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 138000
-vm /usr/bin/java
-vmargs
-jar startup.jar 

Thankyou!
Comment 1 Dan Brady 2006-09-21 19:48:08 EDT
Created attachment 136917 [details]
Screenshot of Error
Comment 2 Ben Konrath 2006-09-21 23:00:56 EDT
Please run eclipse from the command line with -consolelog and post the output.
Can you also post the version you are using? To get this run 'rpm -q
eclipse-platform' on the command line. Thanks. 
Comment 3 Dan Brady 2006-09-22 02:41:45 EDT
[hobodan@HoboLap ~]$ eclipse -consolelog
!SESSION 2006-09-21 23:35:27.951 -----------------------------------------------
eclipse.buildId=M20060629-1905
java.fullversion=GNU libgcj 4.1.1 20060828 (Red Hat 4.1.1-20)
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments:  -os linux -ws gtk -arch x86 -consolelog

!ENTRY org.eclipse.osgi 2 1 2006-09-21 23:35:37.943
!MESSAGE NLS missing message: fileInitializer_missingFileName in:
org.eclipse.core.internal.runtime.messages
/usr/bin/java: symbol lookup error:
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/29/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_StringContainerInit2
[hobodan@HoboLap ~]$ rpm -q eclipse-platform
eclipse-platform-3.2.0-5.fc6
[hobodan@HoboLap ~]$
Comment 4 Andrew Overholt 2006-09-22 08:48:54 EDT
(In reply to comment #3)
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/29/1/.cp/libswt-mozilla-gtk-3232.so:
> undefined symbol: NS_StringContainerInit2

Try rpm -e mozilla
Comment 5 Dan Brady 2006-09-22 13:50:16 EDT
oh wow! thank you so very much! that did the trick! thanks again!

-Dan
Comment 6 Ben Konrath 2006-09-22 14:01:31 EDT
I added "Conflicts: mozilla" to the libswt3-gtk2 sub-package so this shouldn't
happen anymore. This will appear in 3.2.0-7.fc6.
Comment 7 Mary Ellen Foster 2006-10-02 11:08:41 EDT
Will that conflict mess up anything for people upgrading from FC5? I'm trying to
track down a different eclipse-upgrading-from-FC5 problem, and I'm having
trouble doing 'yum --enablerepo=development update eclipse\*' because of that
conflict, and I can't just rpm -e mozilla on this (mostly FC5) system:
sudo rpm -e mozilla
error: Failed dependencies:
        libgtkembedmoz.so is needed by (installed) devhelp-0.11-3.1.fc5.i386
        libgtkembedmoz.so is needed by (installed) yelp-2.14.3-1.fc5.i386
        libgtkembedmoz.so is needed by (installed) libswt3-gtk2-3.1.2-1jpp_15fc.i386
        libmozjs.so is needed by (installed) mozilla-devel-1.7.13-1.1.fc5.i386
        libxpcom.so is needed by (installed) devhelp-0.11-3.1.fc5.i386
        libxpcom.so is needed by (installed) yelp-2.14.3-1.fc5.i386
        libxpcom.so is needed by (installed) mozilla-devel-1.7.13-1.1.fc5.i386
        libxpcom.so is needed by (installed) libswt3-gtk2-3.1.2-1jpp_15fc.i386
        mozilla = 37:1.7.13 is needed by (installed) devhelp-0.11-3.1.fc5.i386
        mozilla >= 1.7.13 is needed by (installed) yelp-2.14.3-1.fc5.i386
        mozilla = 37:1.7.13-1.1.fc5 is needed by (installed)
mozilla-devel-1.7.13-1.1.fc5.i386
        /usr/bin/mozilla is needed by (installed)
eclipse-platform-3.1.2-1jpp_15fc.i386

In particular, it's needed by eclipse-platform, so I can't just "yum remove" it
without removing eclipse, which negates the thing I'm trying to test.
Comment 8 Mary Ellen Foster 2006-10-02 11:16:05 EDT
Okay, the problem with the upgrade was quite probably that I still had the FC5
repositories enabled in yum along with development, so it kept trying to choose
FC5 mozilla instead of FC6 firefox to satisfy the libxpcom.so dependency in
libswt3-gtk2 ... so maybe a false alarm.

Note You need to log in before you can comment on or make changes to this bug.