Bug 207648 - Evolution locks when displaying e-mail with large tiff drawing attached
Evolution locks when displaying e-mail with large tiff drawing attached
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 04:18 EDT by Rene van Paassen
Modified: 2008-03-11 22:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 22:35:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
9000 x 9000 points tiff file that cannot be attached to an evolution message (118.09 KB, image/tiff)
2006-12-04 14:57 EST, Rene van Paassen
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 488213 None None None Never

  None (edit)
Description Rene van Paassen 2006-09-22 04:18:08 EDT
Description of problem:
A colleague sent me an e-mail with two large tiff files attached. One was
13544x9576 pixels, filesize only 182 kB, the other slightly smaller. upon trying
to display this message, evolution starts using 100% cpu time. 

Version-Release number of selected component (if applicable):
evolution-2.6.3-1.fc5.5

How reproducible:
Open e-mail with huge (in pixels) tif file

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Evolution starts using 100% CPU

Expected results:
Mail displayed, images not visible

Additional info:
Comment 1 Matthew Barnes 2006-10-25 12:59:59 EDT
Thanks for the bug report.

As of yesterday, Evolution 2.6 is no longer supported in Fedora Core 5.
Can you please try again with Evolution 2.8 in Fedora Core 6?
Comment 2 Rene van Paassen 2006-11-28 04:21:36 EST
Evolution 2.8 (on x86_64 btw) has the same problem.
Comment 3 Rene van Paassen 2006-12-04 14:57:39 EST
Created attachment 142768 [details]
9000 x 9000 points tiff file that cannot be attached to an evolution message
Comment 4 Rene van Paassen 2006-12-04 15:00:59 EST
Played around with large tiff files with some scribbles in it. Attached
9000x9000 point file cannot be attached to message in evolution. Evolution uses
some memory for the message (but not all in the machine), and then starts to eat
CPU cycles only. 8500x8500 points message can be attached without problems. 
Comment 5 Matthew Barnes 2007-10-06 19:39:13 EDT
Problem still exists in Evolution 2.12.0.
Comment 6 Milan Crha 2007-10-19 06:25:14 EDT
Based on my investigations, the problem is not in evolution itself, but in
gdk_pixbuf_scale. I added this bug to upstream against evolution [1], because
there could be done some improvement. We can move this bug either against gdk or
close, even closing this will not solve this.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=488213
Comment 7 Matthew Barnes 2008-03-11 22:35:51 EDT
Moving upstream to the bug referenced in comment #6.  Looks like there's at
least a partial solution for this in 2.22.

Note You need to log in before you can comment on or make changes to this bug.