Bug 207653 - weak-modules "xargs: nm: No such file or directory" on kernel install
weak-modules "xargs: nm: No such file or directory" on kernel install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: module-init-tools (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jon Masters
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-09-22 05:47 EDT by Matthias Saou
Modified: 2008-04-15 20:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-15 20:24:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-09-22 05:47:12 EDT
On an FC6t3 x86_64 system installed 2 days ago, and updated daily since,
I just got this :

[...]
  Installing: kernel-xen             ####################### [15/54]
xargs: nm: No such file or directory
  Updating  : firstboot-tui          ####################### [16/54]
  Installing: kernel-devel           ####################### [17/54]
  Updating  : pirut                  ####################### [18/54]
  Installing: kernel                 ####################### [19/54]
xargs: nm: No such file or directory
  Updating  : python-xeninst         ####################### [20/54] 
[...]

The scriplets for the kernels don't seem to contain "nm" directly, so I dug a
little and found out that it's from /sbin/weak-modules :

            if [ -e /lib/modules/$module_krel/extra ]; then
                find /lib/modules/$module_krel/extra -name '*.ko' \
                | xargs nm \
                | sed -nre 's:^([0-9a-f]+) A __crc_(.*):0x\1 \2:p'
            fi > $tmpdir/extra-symvers-$module_krel

So if this xargs nm is important, module-init-tools should depend on it, so that
we are sure to have it installed. Otherwise, adding a test for nm's presence and
running the find only if it is found?
Comment 1 Matthias Saou 2006-09-22 10:30:24 EDT
Today's new redhat-lsb-3.1-10.3 has pulled in binutils now (and m4 and gettext
which I didn't have installed either). It's apparently related to bug #202548
(from the %changelog), but I'm not authorized to see that bug...

Since redhat-lsb is in the set of default packages for a default install, I
guess the issue is a lot less important, but still, you might want to also have
module-init-tools require binutils if having "nm" is really important.
Comment 2 Ville Skyttä 2006-10-27 01:59:23 EDT
The issue still persists as of FC6 final.

binutils is a large package, so a solution which wouldn't require a dependency 
on it in module-init-tools would be nice.  +1 to something like described in 
the initial comment (testing if /usr/bin/nm exists and only proceeding if it 
does).
Comment 3 Jon Masters 2007-08-20 02:35:00 EDT
Is this still an issue in F7?

Jon.
Comment 4 Matthias Saou 2007-08-22 04:50:01 EDT
I just looked at /sbin/weak-modules on my F7 system and the section that calls
"nm" doesn't seem to have changed, and it's still pretty easy to not have
binutils installed (although it's now pulled in by redhat-lsb apparently).

So I'd think the bug is still present, yes.
Comment 5 Jon Masters 2008-04-02 17:47:57 EDT
I've updated weak-modules.

Note You need to log in before you can comment on or make changes to this bug.