Bug 207654 - Support for Kolab annotations
Support for Kolab annotations
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: cyrus-imapd (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Horák
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 05:59 EDT by Szombathelyi György
Modified: 2008-07-31 11:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-31 11:00:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Some custom annotations which are neccessary for kolab2 clients. (1.06 KB, patch)
2006-09-22 05:59 EDT, Szombathelyi György
no flags Details | Diff

  None (edit)
Description Szombathelyi György 2006-09-22 05:59:59 EDT
Description of problem:

Unpatched cyrus imap server cannot be used as a kolab2 client, since it doesn't
support the required annotations (/vendor/kolab/...)

Version-Release number of selected component (if applicable):

All cyrus-imapd versions

How reproducible:

Just try to use e.g. Toltec Connector, it will say annotations not supported.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

I attached a patch which works with all current kolab clients, and absolutely
safe, non-intrusive.

That would be nice if it can be added till FC6 release!
Comment 1 Szombathelyi György 2006-09-22 05:59:59 EDT
Created attachment 136936 [details]
Some custom annotations which are neccessary for kolab2 clients.
Comment 2 Szombathelyi György 2007-01-25 18:47:03 EST
Any chances that this patch will be included?
Comment 3 Tomas Janousek 2007-01-26 06:28:03 EST
Did you try to put it upstream? Would they accept it?
Comment 4 Szombathelyi György 2007-01-26 06:44:39 EST
I posted it to:
http://www.intevation.de/pipermail/kolab-devel/2006-September/005957.html
and also filed a bug report in cyrus bugzilla, which I cannot reach currently...
This patch is a bit kolab-specific, so maybe it'll not accepted upstream, but it
would be good to have in Fedora (as I see there are more complex patches in the
Fedora version, this one is very simple and non-intrusive).
Comment 5 Tomas Janousek 2007-01-29 10:10:45 EST
What is the bz number in cyrus bz?  I'd like to Cc it.

I'm not sure whether I like the idea of having such vendor-specific patch in the
package.  I'd rather help with reviewing and testing Thomas' patch (
http://vman.de/cyrus/ ) since that seems to be better and more general solution.

Btw, accoring to the ietf drafts, the vendors must be registered and x-toltec is
not, according to http://www.iana.org/assignments/acap-registrations .
Comment 6 Szombathelyi György 2007-01-29 10:35:01 EST
I like Thomas' patch, I also thinked that going to implementing the same
idea...I'll try testing.
According to the x-toltec annotation, the author of Toltec Connector said that
he will change this after something for this problem goes upstream.
Comment 7 Szombathelyi György 2007-01-29 10:37:23 EST
Here's the bugreport for cyrus (my comment is #8):
https://bugzilla.andrew.cmu.edu/show_bug.cgi?id=2458

But this is the same as mentioned in http://vman.de/cyrus/
Comment 8 Bug Zapper 2008-04-03 14:17:44 EDT
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 9 Szombathelyi György 2008-04-04 19:59:54 EDT
Kolab server has choosen Thomas Viehmann's patch, so I'm wondering if the 
Fedora version can include it.
Comment 10 Dan Horák 2008-05-13 04:09:35 EDT
But we need that CMU will choose the patch. So try to ping them in their bugzilla.
Comment 11 Bug Zapper 2008-05-13 22:22:19 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Note You need to log in before you can comment on or make changes to this bug.