Bug 2076618 (CVE-2021-25746) - CVE-2021-25746 k8s.io/ingress-nginx: directive injection via annotations
Summary: CVE-2021-25746 k8s.io/ingress-nginx: directive injection via annotations
Keywords:
Status: CLOSED NOTABUG
Alias: CVE-2021-25746
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 2076624
TreeView+ depends on / blocked
 
Reported: 2022-04-19 13:56 UTC by Guilherme de Almeida Suckevicz
Modified: 2022-11-14 19:35 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
A flaw was found in the ingress-nginx controller. When a user creates or updates ingress objects, credentials of the ingress-nginx controller can be obtained by accessing .metadata.annotations.
Clone Of:
Environment:
Last Closed: 2022-04-26 09:15:56 UTC


Attachments (Terms of Use)

Description Guilherme de Almeida Suckevicz 2022-04-19 13:56:04 UTC
A security issue was discovered in ingress-nginx where a user that can create or update ingress objects can use `.metadata.annotations` in an Ingress object (in the `networking.k8s.io` or `extensions` API group) to obtain the credentials of the ingress-nginx controller. In the default configuration, that credential has access to all secrets in the cluster. This bug affects ingress-nginx. If you do not have ingress-nginx installed on your cluster, you are not affected. You can check this by running `kubectl get po -n ingress-nginx`. Multitenant environments where non-admin users have permissions to create Ingress objects are most affected by this issue.

Comment 1 Product Security DevOps Team 2022-04-26 09:15:54 UTC
This bug is now closed. Further updates for individual products will be reflected on the CVE page(s):

https://access.redhat.com/security/cve/cve-2021-25746


Note You need to log in before you can comment on or make changes to this bug.