Bug 207731 - Anaconda fails to update ramdisks with 3ware driver from driver disk during OS installation.
Anaconda fails to update ramdisks with 3ware driver from driver disk during O...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
5
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 15:20 EDT by Michael Benz
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 17:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
32 bit FC5 dd disk image (1.41 MB, application/octet-stream)
2006-09-22 15:20 EDT, Michael Benz
no flags Details

  None (edit)
Description Michael Benz 2006-09-22 15:20:09 EDT
Description of problem: If you boot the installer with the linux dd option and
walk through the prompts to insert the driver disk you will see that it loads
the appropriate driver during installation but fails to update the
/lib/modules/2.6.15-1.2054_FC5xxx/updates directory with the update drivers so
when mkinitrd is run the shipping in kernel driver (2.26.05.002) is added to the
ram disk. This is a problem when installing to our new controller since this
driver has no support for the controller, if you are installing to a disk on the
controller upon booting the system it fails to boot. I have verified this on
both x86 and x86_64, the work around I am providing our test group is to go to a
console just prior to reboot of the install and mcopy the driver from the floppy
to the appropriate place then chroot /mnt/sysimage and run mkinitrd again. This
works but will be a hassle for end users.

Version-Release number of selected component (if applicable):
FC5 x86 and FC5 x86_64

How reproducible:
Everytime.

Steps to Reproduce:
1. Boot install from CD or DVD with linux dd, use the x86 dd disk image attached
2. Follow prompts for driver disk then stop at reboot screen.
3. Go to a console and cat /sysfs/module/3w_9xxx/version to see 2.26.02.009.
4. Finish installation
5. If you are not booting from the controller login and cat
/sysfs/module/3w_9xxx/version and you will see the wrong driver, it should be
2.26.02.009
  
Actual results:
Uses updated driver for install but loads in kernel driver into ramdisk

Expected results:
Setup ramdisk with updated drivers from driver disk

Additional info:
Comment 1 Michael Benz 2006-09-22 15:20:11 EDT
Created attachment 136965 [details]
32 bit FC5 dd disk image
Comment 2 David Cantrell 2007-03-15 16:40:56 EDT
Try with rawhide or a Fedora 7 test release.  If the failure continues under any
of those releases, please attach /tmp/anaconda.log.
Comment 3 Red Hat Bugzilla 2007-06-11 23:17:55 EDT
requested by Jams Antill
Comment 4 Chris Lumens 2007-08-24 17:24:46 EDT
We've done a lot of fixes around driver disks for the next release, so this
should be fixed up for F8.  If you still experience problems, please feel free
to reopen this bug.
Comment 5 Michael Benz 2007-08-24 17:46:15 EDT
Thanks for looking into this problem. I think part of the problem was the fact I
was using an old format driver disk so it was missing the extra files added in
the new format. It did however load the correct driver during install as I
pointed out so it was somewhat working. With the new format I am unable to
reproduce on FC5 or FC6.


Note You need to log in before you can comment on or make changes to this bug.