Bug 207762 - evince triggers PDF detection on file extension
evince triggers PDF detection on file extension
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evince (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kristian Høgsberg
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-22 17:52 EDT by Rik van Riel
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 22:36:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rik van Riel 2006-09-22 17:52:45 EDT
Description of problem:

Evince refuses to render (some?) PDFs when the file name does not end in ".pdf".

This is a big issue when trying to open a PDF from a mail reader or browser,
which may use a temporary filename not ending in ".pdf".

Renaming the file to <file>.pdf makes evince render the file just fine...

Version-Release number of selected component (if applicable):

evince-0.6.0-1.fc6

Steps to Reproduce:
1. mv <file>.pdf <file>
2. evince <file>
3. watch it fail
4. mv <file> <file>.pdf
5. evince <file>.pdf
6. now it works

Additional info:

C:\>
Comment 1 Ralph Loader 2006-11-07 01:53:59 EST
This seems to be fixed in fc6.
Comment 2 Matthias Clasen 2006-11-09 22:32:51 EST
Can you attach an example ? It worked fine when I tried it here.
Comment 3 Rik van Riel 2006-11-09 22:36:24 EST
Then I guess it got fixed :)

If it happens again in the future I'll reopen.

Note You need to log in before you can comment on or make changes to this bug.