Bug 207780 - Unable to boot a newly installed FC6T3 system on x86-64
Unable to boot a newly installed FC6T3 system on x86-64
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2006-09-22 23:23 EDT by Srihari Vijayaraghavan
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-09-28 19:15:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
FC6T3 kernel dmesg (11.05 KB, text/plain)
2006-09-22 23:23 EDT, Srihari Vijayaraghavan
no flags Details

  None (edit)
Description Srihari Vijayaraghavan 2006-09-22 23:23:36 EDT
Description of problem:
Newly install FC6T3 system on x86-64 doesn't boot successfully. It boots and
immediately automatically reboots. Suspected Kernel/File system (file system
misdetection) issue.

Version-Release number of selected component (if applicable):
FC6T3, 2.6.17-1.2630.fc6

How reproducible:
Always. (3 times proven)

Steps to Reproduce:
1. Install
2. Boot
3. Observe it to reboot during the bootup sequence
Actual results:
Automatically reboots.

Expected results:
To bootup successfully.

Additional info:
Refer to serial console captured kernel logs. It'd seem ext3 file system is
being accessed as ext2, as confirmed by EXT2-fs & SELinux messages.

A few times, during the installation procedure, I've confirmed that the file
system selection was indeed ext3 & also subsequently, by switching to a virtual
console, confirmed that the choosen file system was indeed mounted as ext3 by
consulting kernel logs (ie, EXT3-fs & SELinux messages of the installation kernel).
Comment 1 Srihari Vijayaraghavan 2006-09-22 23:23:36 EDT
Created attachment 136989 [details]
FC6T3 kernel dmesg
Comment 2 John A. Pounds 2006-09-23 22:24:29 EDT
I too experienced this.  I used the x86-64 DVD. I have an Asus M2V, with a VIA
K8T890 chipset. I was able to use the i386 DVD to get a working system.

Initially I couldn't get the x86-64 DVD install to work.  I checked bugzilla and
found someone with a similar problem, and the resource asked if them if there
were any ReiserFS partitions. They replied yes, so I deleted my ReiserFS
partition and then the install worked.  I formatted the partition as an ext3
partion. However, once the install completed, the automatic reboots occurred.  I
had four primary partitions: Windows XP 64 NTFS (1), Swap (2), ext3 (4), and a
Fat32 (3).
Comment 3 Srihari Vijayaraghavan 2006-09-24 01:37:05 EDT
Could it be because it lacks an initrd image? (there's no initrd file on x86-64
installation, while there's one on x86)

Comment 4 Srihari Vijayaraghavan 2006-09-24 03:38:51 EDT
Creating initrd image manually solved the problem.
(1. Bbooted on rescue mode [using the DVD]
2. Located the right FC6T3 system, & had it mounted by the rescue program
3. Chrooted to that system
4. Created an initrd image
5. Added a ref to it in the grub boot loader
6. Booted the system successfully :-))

It'd be a good idea for FC6 installer to create the initrd image & a ref for it
in the boot loader.

Comment 5 Dave Jones 2006-09-28 19:15:43 EDT
The lack of an initrd was an anaconda bug in test3 that should now be fixed.

Note You need to log in before you can comment on or make changes to this bug.