Bug 207844 - The command `w` only outputs a header
The command `w` only outputs a header
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: procps (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 11:40 EDT by rob
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-03 09:25:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
`strace w` output (61.75 KB, application/octet-stream)
2006-09-27 19:47 EDT, rob
no flags Details

  None (edit)
Description rob 2006-09-24 11:40:01 EDT
Description of problem:
The `w` command does not report any user statistics

Version-Release number of selected component (if applicable):
procps-3.2.7-6

How reproducible:
every time

Steps to Reproduce:
1. type `w`
2.
3.
  
Actual results:
Code output...
[root@grumpy ~]# cat /etc/fedora-release
Fedora Core release 5.92 (FC6 Test3)
[root@grumpy ~]# rpm -q --whatprovides /usr/bin/w
procps-3.2.7-6
[root@grumpy ~]# w
 11:38:06 up 17:07,  0 users,  load average: 0.07, 0.12, 0.05
USER     TTY      FROM              LOGIN@   IDLE   JCPU   PCPU WHAT
[root@grumpy ~]#


Expected results:


Additional info:
Comment 1 rob 2006-09-24 11:46:56 EDT
Could it be my setup? I now see that `users` reports empty as well...

[root@grumpy ~]# users
[root@grumpy ~]# 
[root@grumpy ~]# rpm -q --whatprovides /usr/bin/users
coreutils-5.97-9
[root@grumpy ~]#   
Comment 2 Karel Zak 2006-09-27 06:04:41 EDT
I can't reproduce this your problem. It seem there is something other wrong in
your system. Do you have mounted the /proc filesystem? You can also try strace
the 'w' process.
Comment 3 rob 2006-09-27 19:47:50 EDT
Created attachment 137273 [details]
`strace w` output
Comment 4 rob 2006-09-27 19:49:24 EDT
Thank you for your reply. Yes, /proc is mounted.

[root@grumpy ~]# mount
/dev/mapper/RootOS-Root on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/md0 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/mapper/RootOS-Home on /home type ext3 (rw)
/dev/mapper/RootOS-Opt on /opt type ext3 (rw)
/dev/mapper/RootOS-Tmp on /tmp type ext3 (rw)
/dev/mapper/RootOS-Usr on /usr type ext3 (rw)
/dev/mapper/RootOS-Var on /var type ext3 (rw)
/dev/mapper/RootOS-export on /export type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
[root@grumpy ~]#                                             
Comment 5 rob 2006-09-27 20:18:34 EDT
Thank you for your reply. Yes, /proc is mounted.

[root@grumpy ~]# mount
/dev/mapper/RootOS-Root on / type ext3 (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
/dev/md0 on /boot type ext3 (rw)
tmpfs on /dev/shm type tmpfs (rw)
/dev/mapper/RootOS-Home on /home type ext3 (rw)
/dev/mapper/RootOS-Opt on /opt type ext3 (rw)
/dev/mapper/RootOS-Tmp on /tmp type ext3 (rw)
/dev/mapper/RootOS-Usr on /usr type ext3 (rw)
/dev/mapper/RootOS-Var on /var type ext3 (rw)
/dev/mapper/RootOS-export on /export type ext3 (rw)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
sunrpc on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw)
nfsd on /proc/fs/nfsd type nfsd (rw)
[root@grumpy ~]#                                             
Comment 6 Karel Zak 2006-10-05 18:54:43 EDT
It seems like a problem with /var/run/utmp - I think you have problem with more
commands (w, users, last, ...)
Comment 7 Brian Daniels 2006-10-27 17:36:48 EDT
Having the same problem here on a clean install of FC6 release.  'w' shows
nothing but the header.  'users' gives no response. 'last' seems to be working.
Comment 8 Karel Zak 2007-04-03 06:27:44 EDT
Do you have same problem on updated FC6?
Comment 9 Brian Daniels 2007-04-03 08:41:42 EDT
Working fine for me at this point.
Comment 10 Karel Zak 2007-04-03 09:25:11 EDT
Thanks for your feedback.

Note You need to log in before you can comment on or make changes to this bug.