Bug 207871 - scim-anthy disabled in non-Japanese environment (no toggle)
scim-anthy disabled in non-Japanese environment (no toggle)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: scim-anthy (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Akira TAGOH
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-24 20:40 EDT by Shannon Jacobs
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 01:56:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shannon Jacobs 2006-09-24 20:40:08 EDT
Description of problem:

When scim-anthy is installed, the Japanese input is only available when Japanese
is the default language, but it should be available at all times. Many users may
need to input Japanese even though they are working from another language.
(Pretty sure this affects other input systems using scim, but I didn't test them.)

My current hypothesis is that the scim environment information is being
installed at a lower level than it should be.

Version-Release number of selected component (if applicable):
NA

How reproducible:
Seems to be absolutely consistent, and the workaround shown below is alos firmly
and consistently linked to the specific environment where it is invoked.

Steps to Reproduce:
1. Install scim-anthy 
2. Hit activation hotkey (eiher the zenkaku/hankaku key or <Ctrl>-<space>
3. Nothing happens in English environment, Anthy toggles on in Japanese env.
  
Actual results:
In English environment, nothing happens

Expected results:
Japanese input mode should become active (or inactive--it's a toggle).

Additional info:

On Saturday I briefly discussed this problem with a distro-free Linux guru, and
he quickly gave me the following generic fix. I have confirmed that using the
third command is sufficient, at least to activate gedit with Japanese input
capability from a shell where that command has been invoked. However, I'm such a
newbie to Fedora that I don't know how to apply it in a safe way. (I called the
fix 'generic' because it is also applicable to solving what seems to be the same
problem under Ubuntu.)

LANG='ja_JP.UTF-8' scim -d
export XMODIFIERS=@im=SCIM
export GTK_IM_MODULE=scim
export QT_IM_MODULE=scim
Comment 1 Akira TAGOH 2006-09-25 01:56:48 EDT
Please make a symlink under ~/.xinput.d like:

$ ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/default

and restart your desktop. it makes scim default for all languages.

FYI on FC6, we will provides a GUI tool to configure the IM for desktop,
so-called im-chooser.

anyway, this behavior is not a bug. we didn't make scim running by default was
intentional.
Comment 2 Shannon Jacobs 2006-09-25 20:37:07 EDT
Sounds like a good solution. However, when I tried it, the response was:

$ ln -s /etc/X11/xinit/xinput.d/scim ~/.xinput.d/default
ln: creating symbolic link `/home/shanen/.xinput.d/default' to
`/etc/X11/xinit/xinput.d/scim': No such file or directory

I checked that the scim file exists in the specified location, and for grins I
even used su and tried it as root.

I understand that you did this intentionally, but that seems odd. Why would
someone install scim unless they had the intention of using it?

However, if I actually understand what the recommended solution is supposed to
do, it also seems to be unsuccessful. I think the recommendation is to make sure
that scim is running, but just having scim running does not seem to be
sufficient. At least is is not working in my tests. It still seems to require
the GTK environment setting.
Comment 3 Akira TAGOH 2006-09-25 22:36:13 EDT
I don't see why ln failed. or did you install scim from tarball? FWIW this is a
FC specific way. if you tried it on non-FC box or installed scim without the
package, then it fails.

please provide the package version of scim. try this:

$ rpm -qa scim
Comment 4 Akira TAGOH 2006-09-25 22:37:09 EDT
I mean rpm -q scim.
Comment 5 Shannon Jacobs 2006-09-26 03:24:50 EDT
I installed scim-anthy using yum. If I remember correctly, I used the command
"yum install scim-anthy" to do it.

However, I'm pretty sure the problem was that the .xinit.d subdirectory did not
exist. I just created that directory with "mkdir .xinit.d", and then the
recommended workaround command worked. I can't restart X11 just now, but I will
later, and if I don't post again, you may take it as confirmation of success.

Note You need to log in before you can comment on or make changes to this bug.