RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2078974 - DISA STIG oscap profile results in a rsyslog.conf which is configured for tcp forwarding without queues
Summary: DISA STIG oscap profile results in a rsyslog.conf which is configured for tcp...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: scap-security-guide
Version: 8.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Vojtech Polasek
QA Contact: Milan Lysonek
Jan Fiala
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-26 15:55 UTC by Lark Gordon
Modified: 2022-11-08 10:34 UTC (History)
8 users (show)

Fixed In Version: scap-security-guide-0.1.63-2.el8
Doc Type: Bug Fix
Doc Text:
.Warning added to `rsyslog_remote_loghost` The SCAP rule `xccdf_org.ssgproject.content_rule_rsyslog_remote_loghost` ensures that the Rsyslog daemon is configured to send log messages to a remote log host. However, the rule does not configure TCP queues. As a consequence, the system hangs if TCP queues are not configured, and the remote log host becomes unavailable. This update adds a warning message that explains how to configure TCP queues. If you encounter system hangs while using this rule, read the warning and configure the system properly.
Clone Of:
Environment:
Last Closed: 2022-11-08 09:39:56 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-120010 0 None None None 2022-04-26 16:02:28 UTC
Red Hat Product Errata RHBA-2022:7563 0 None None None 2022-11-08 09:40:30 UTC

Description Lark Gordon 2022-04-26 15:55:30 UTC
Description of problem:

Scans for ssg-rhel8-ds.xml using the xccdf_org.ssgproject.content_profile_stig_gui suggest configuring tcp forwarding for rsyslog, but do not indicate that a queue must also be used as queue-less tcp forwarding is not supported.

Version-Release number of selected component (if applicable):
openscap-scanner-1.3.5-6.el8.x86_64
openscap-1.3.5-6.el8.x86_64
scap-security-guide-0.1.57-5.el8.noarch

How reproducible:
Every time

Steps to Reproduce:
1. Install a new RHEL 8 system
2. Scan using /usr/share/xml/scap/ssg/content/ssg-rhel8-ds.xml and --profile xccdf_org.ssgproject.content_profile_stig_gui
3. The scan results indicate that forwarding should be configured, but not that a queue is needed. If you allow the scan to remediate, the following line is added to /etc/rsyslog.conf: 

    *.* @@logcollector

Actual results:

------------------------------
xccdf_org.ssgproject.content_rule_rsyslog_remote_loghost
...
To configure rsyslog to send logs to a remote log server, open /etc/rsyslog.conf and read and understand the last section of the file, which describes the multiple directives necessary to activate remote logging. Along with these other directives, the system can be configured to forward its logs to a particular log server by adding or correcting one of the following lines, substituting logcollector appropriately. The choice of protocol depends on the environment of the system; although TCP and RELP provide more reliable message delivery, they may not be supported in all environments.
To use UDP for log message delivery:
*.* @logcollector

To use TCP for log message delivery:
*.* @@logcollector

To use RELP for log message delivery:
*.* :omrelp:logcollector
------------------------------

Expected results:
The scan/remediation should include a queue setup for tcp forwarding

Additional info:

Comment 6 Vojtech Polasek 2022-08-09 15:14:18 UTC
Fixed upstream: https://github.com/ComplianceAsCode/content/pull/9305

Comment 20 errata-xmlrpc 2022-11-08 09:39:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (scap-security-guide bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2022:7563


Note You need to log in before you can comment on or make changes to this bug.