Bug 207905 - No bling for me on FC6 test 3/rawhide
Summary: No bling for me on FC6 test 3/rawhide
Status: CLOSED DUPLICATE of bug 204810
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
(Show other bugs)
Version: 6
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-25 10:13 UTC by Ralph Angenendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-02 19:40:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg.conf (733 bytes, text/plain)
2006-09-25 10:15 UTC, Ralph Angenendt
no flags Details
Xorg logfile (122.54 KB, text/plain)
2006-09-25 10:19 UTC, Ralph Angenendt
no flags Details
lspci -v output regarding the graphics card (528 bytes, text/plain)
2006-09-25 10:19 UTC, Ralph Angenendt
no flags Details

Description Ralph Angenendt 2006-09-25 10:13:31 UTC
Description of problem:
When trying to turn on composite with "gnome-window-decorator &; compiz --replace gconf" X stops responding to anything. From the local machine only powercycling is possible.

Version-Release number of selected component (if applicable):
compiz: compiz-0.0.13-0.25.20060817git.fc6, xorg-x11-server-Xorg-1.1.1-38.fc6, xorg-x11-drv-ati-6.6.2-1.fc6. The card is a M9 (Mobility 9000) in a Thinkpad T40.

How reproducible:
"gnome-window-decorator &; compiz --replace gconf". Works ever time.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
System hangs

Expected results:
System gets *bling*

Additional info: Attached: xorg.conf, lspci output for the graphics card, Xorg.log

Comment 1 Ralph Angenendt 2006-09-25 10:15:05 UTC
Created attachment 137038 [details]
xorg.conf

The xorg.conf (unchanged from after installation)

Comment 2 Ralph Angenendt 2006-09-25 10:19:22 UTC
Created attachment 137039 [details]
Xorg logfile

Comment 3 Ralph Angenendt 2006-09-25 10:19:59 UTC
Created attachment 137040 [details]
lspci -v output regarding the graphics card

Comment 4 Ralph Angenendt 2006-09-25 10:23:56 UTC
After calling compiz --replace gconf, the machine seems to be completely dead,
it's not reachable via network anymore

Comment 5 David Cantrell 2006-09-25 16:59:14 UTC
This has been happening to me ever since FC6 Test 2.  Still happening to me on
rawhide.

I have a Thinkpad T42 with a Radeon Mobility 7500.

The workaround I received from another bug report about this was to login in
failsafe mode, run 'desktop-effects', uncheck Enable Desktop Effects, then
recheck it, logout, and proceed with a normal GNOME login method.

If I don't do this, the machine will lock up each time I login.  I have to do
this desktop-effects checkbox thing each time in failsafe mode if I don't want
it to lock up on normal login.

Compiz *does* run for me and the bling does work.  But I have to play with
desktop-effects before I can run it.

Bizarre and annoying.

Comment 6 Thomas J. Baker 2006-09-25 18:28:22 UTC
This looks similar to my bug #204810. It's quite annoying in it's randomness. It
worked all weekend for me and this morning at work, I had to disable compiz
again after three hangs at first login.

Comment 7 Clyde E. Kunkel 2006-09-29 16:10:35 UTC
After today's (9/29/06) rawhide update, bling is back for me after experiencing
freezeups for since FC3T3. Radeon 9200 AGP on i386 system.  Invoked from a
gnome-terminal window and did see the following:

[kunkelc@P4C800ED ~]$ desktop-effects                        <---turn on effects
libGL warning: 3D driver claims to not support visual 0x4b
compiz: water: GL_ARB_fragment_program is missing
compiz: water: GL_ARB_fragment_program is missing
compiz: water: GL_ARB_fragment_program is missing
[kunkelc@P4C800ED ~]$ desktop-effects                        <---turn off
[kunkelc@P4C800ED ~]$ 


Comment 8 Kristian Høgsberg 2006-10-02 17:30:54 UTC
I can't consistently reproduce this crash, though I've gotten it to lock up a
few times.  Could you guys try adding

  Option "XaaNoOffscreenPixmaps"

to the "Device" section of your xorg.conf files?

Thanks,
Kristian

Comment 9 Kristian Høgsberg 2006-10-02 19:40:24 UTC

*** This bug has been marked as a duplicate of 204810 ***

Comment 10 Kristian Høgsberg 2006-10-02 23:02:52 UTC
This bug should be fixed and the new build will be in rawhide soon.  In the
meantime, you can get it here:

  http://people.redhat.com/krh/xorg-x11-server-Xorg-1.1.1-44.fc6.i386.rpm

Please give it a try and let me know how it goes.



Note You need to log in before you can comment on or make changes to this bug.