Bug 207912 - Server X cannot start
Summary: Server X cannot start
Status: CLOSED DUPLICATE of bug 203017
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: ia64 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Adam Jackson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-25 11:56 UTC by noye
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-25 18:10:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Contains startx outputs, Xorg.0.log,X.stdout,Xconfig.test,fisrtboot-crash.log (28.58 KB, text/plain)
2006-09-25 11:56 UTC, noye
no flags Details

Description noye 2006-09-25 11:56:32 UTC
Description of problem:
On linux boot on a Tiger server X server cannot start.
Last displayed messages on screen are:

Probing for Video Card : ATI Technonlogy Inc Rage XL
Attempting to start native X server
Waiting for X server to start ... log located in /dev/null
1...2...3...4...5...X server started successfully
  File "/usr/sbin/firstboot", line 107, in ?
    fb.startGraphicalUI()
  File "/usr/share/firstboot/xfirstboot.py", line 74, in startGraphicalUI
    import gtk
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 76, 
in ?
    _init()
  File "/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 64, in 
_init
    _gtk.init_check()
RuntimeError: could not open display


With startx command use, error messages are:

(EE) ATI(0): Adapters found to be in VGA mode on server entry are not 
supported by the MMIO-only version of this driver.
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
XIO:  fatal IO error 104 (Connection reset by peer) on X server ":0.0"
      after 0 requests (0 known processed) with 0 events remaining.



Version-Release number of selected component (if applicable):
Build ID: xorg-x11-server 1.1.1-25.fc6 ?

How reproducible:
Rebooting Linux or starting X server (with startx command)

Steps to Reproduce:
1.
2.
3.
  
Actual results:

No server X starts

Expected results:

Start of X server

Additional info:

Comment 1 noye 2006-09-25 11:56:33 UTC
Created attachment 137042 [details]
Contains startx outputs, Xorg.0.log,X.stdout,Xconfig.test,fisrtboot-crash.log

Comment 2 Adam Jackson 2006-09-25 18:10:25 UTC

*** This bug has been marked as a duplicate of 203017 ***


Note You need to log in before you can comment on or make changes to this bug.