Bug 207923 - RFE: update to dbus-0.62
RFE: update to dbus-0.62
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: FutureFeature
Depends On:
Blocks: 207924
  Show dependency treegraph
 
Reported: 2006-09-25 09:15 EDT by Rex Dieter
Modified: 2013-03-13 00:51 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-18 11:58:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to export DBUS_SESSION_BUS_PID in the "run another program" case (933 bytes, patch)
2006-10-03 13:07 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Rex Dieter 2006-09-25 09:15:59 EDT
I'd *really* like to be able to enable qt4 dbus bindings for FC-5 (and allow
folks to start playing with kde4 there), but that requires (at least) dbus-0.62
(or so says qt4's %configure scriptlet)
Comment 1 Kevin Kofler 2006-09-25 09:41:22 EDT
FYI, I have built and installed D-Bus 0.62 for FC5 (replacing the official 0.61 
RPM) and I didn't encounter any issues with it. (I based my specfile off the 
official one.)
Comment 2 Kevin Kofler 2006-10-03 13:07:22 EDT
Created attachment 137670 [details]
patch to export DBUS_SESSION_BUS_PID in the "run another program" case

I think we'll also need something like the attached patch, because KDE 4 (or
QDBus?) expects DBUS_SESSION_BUS_PID to be set. (At least, that's what the
startkde script claims.) This patch ensures that this will be set in the X11
session started through:
/usr/bin/dbus-launch --exit-with-session /etc/X11/xinit/Xclients
from the scripts in /etc/X11/xinit. (The goal is to make KDE 4 apps in
non-KDE-4 sessions work.)

Is this patch acceptable? (If so, can it go upstream?) Or is it wrong for KDE 4
to expect this to be set?
Comment 3 John (J5) Palmieri 2006-10-03 13:15:12 EDT
It really should not rely on the PID.  
Comment 4 John (J5) Palmieri 2006-10-03 13:18:09 EDT
Davidz, can you update FC5 when you get a chance?  This looks like a good reason
for an update.  Note, if Qt4 stops working with 0.62 we won't be able to update
anymore.
Comment 5 Kevin Kofler 2006-10-03 13:25:03 EDT
Oh, by the way, please don't take the DBUS_SESSION_BUS_PID issue as a blocker 
for the upgrade, the 0.62 upgrade alone (without that patch) should be enough 
to get QDBus (and thus the KDE 4 snapshots) to work, the environment variable 
can always be set by hand when needed.

> Note, if Qt4 stops working with 0.62 we won't be able to update anymore.

Understood. I've seen the amount of fixes which were needed for newer versions 
of D-Bus in the Rawhide reports, so this is not a surprise to me.
Comment 6 Kevin Kofler 2006-10-03 15:24:49 EDT
Comment on attachment 137670 [details]
patch to export DBUS_SESSION_BUS_PID in the "run another program" case

I've looked into the Qt 4.2 D-Bus binding and the KDE 4 SVN: exporting the PID
doesn't seem to be actually needed after all, I don't see it used anywhere. So
the patch is probably safe to ignore, we only need the update. :-)
Comment 7 Rex Dieter 2006-11-16 16:11:23 EST
ping, it's been over a month...
Comment 8 Rex Dieter 2006-12-06 09:11:40 EST
ping, another 2 weeks.  Anyone out there?  echo... echo... echo...
Comment 9 John (J5) Palmieri 2006-12-07 19:10:06 EST
Sorry, davidz and I have been busy swapping positions and getting running in our
respective rolls.  Give us another week to get this in, there are some bugfixes
I would like to backport and it doesn't make sense to do two D-Bus releases
since they require a reboot pre 1.0.
Comment 10 Rex Dieter 2006-12-08 07:55:45 EST
Thanks John.
Comment 11 Laurent Rineau 2006-12-15 08:08:20 EST
dbus-0.62 has been pushed to FC-5 (and surely FC>5 too).

dbus-qt should be upgraded, know, so that yum can upgrade everything: because 
dbus-qt has "Requires: dbus-%{version}".
Comment 12 Rex Dieter 2006-12-15 08:18:16 EST
yep, dbus-qt is (re)building now.
Comment 13 Kevin Kofler 2006-12-15 19:05:02 EST
And what about qt4-dbus?
Comment 14 Kevin Kofler 2006-12-15 19:08:42 EST
Oh, scratch that, I forgot it's part of the main qt4 package, not a subpackage, 
and I see you enabled it already.
Comment 15 Rex Dieter 2006-12-18 11:58:31 EST
update is in the wild, closing -> NEXTRELEASE.
Comment 16 Kevin Kofler 2006-12-18 12:01:32 EST
Sorry for being pedantic, but IMHO this should be closed as ERRATA, not 
NEXTRELEASE. ;-)

Note You need to log in before you can comment on or make changes to this bug.