Bug 2079295 - Busybox requires ld-musl-x86_64.so.1, but must be static
Summary: Busybox requires ld-musl-x86_64.so.1, but must be static
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: busybox
Version: 37
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2160300 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-27 10:48 UTC by Anton Guda
Modified: 2023-01-19 13:13 UTC (History)
13 users (show)

Fixed In Version: busybox-1.36.0-1.fc37 busybox-1.36.0-1.fc36
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-01-19 06:10:23 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Anton Guda 2022-04-27 10:48:59 UTC
Description of problem:
Busybox is a special binary, which must be static. However, it requires
so from musl library.


Version-Release number of selected component (if applicable):
busybox-1:1.35.0-4.fc37.x86_64

How reproducible:
Always


Steps to Reproduce:
1. rpm -Uvh --test busybox-1.35.0-4.fc37.x86_64.rpm

Actual results:
error: Failed dependencies:
ld-musl-x86_64.so.1()(64bit) is needed by busybox-1:1.35.0-4.fc37.x86_64


Expected results:
Clean install without dependencies from any library. 


Additional info:

Comment 1 Ben Cotton 2022-08-09 13:15:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 37 development cycle.
Changing version to 37.

Comment 2 Jonas Ådahl 2022-08-16 22:44:13 UTC
This issue breaks using `virtme-run` with -script-sh or -script-exec, as that works by copying the assumingly static /usr/sbin/busybox into a initramfs where it will assume it'll work without external shared objects. It doesn't, however, unless one *also* copies /lib/ld-musl-x86_64.so.1 into /lib in the initramfs. Doing that, I'd say is a work around, one should be able to assume /usr/sbin/busybox is a static executable, can one not, assuming no busybox-shared etc is installed.

This applies to F36 too. Should I clone this bug for F36?

Some other observations:

In F35, `ldd /usr/sbin/busybox` gives me "not a dynamic executable" while on F36 I get

	linux-vdso.so.1 (0x00007ffc89161000)
	ld-musl-x86_64.so.1 => /lib/ld-musl-x86_64.so.1 (0x00007fa94925e000)

Comment 3 Marcos Mello 2022-10-11 19:06:33 UTC
From busybox-1.35.0-4.fc36.x86_64:

$ rpm -qi busybox | grep Summary
Summary     : Statically linked binary providing simplified versions of system commands

$ rpm -qlv busybox | grep /usr/sbin
lrwxrwxrwx    1 root     root                       28 abr  8  2022 /usr/lib/.build-id/31/dce81049eeba32603072cedae67e731390c0e3 -> ../../../../usr/sbin/busybox
-rwxr-xr-x    1 root     root                  1245312 abr  8  2022 /usr/sbin/busybox
lrwxrwxrwx    1 root     root                        9 abr  8  2022 /usr/sbin/busybox.musl.static -> ./busybox

$ ldd /usr/sbin/busybox
        linux-vdso.so.1 (0x00007ffe90ee9000)
        ld-musl-x86_64.so.1 => /lib/ld-musl-x86_64.so.1 (0x00007f4f4f6aa000)

Not static at all. :(

Comment 4 Michael Hofmann 2023-01-05 09:00:07 UTC
As another data point, this broke the upgrade of the RH kernel CI infrastructure from FC35 -> FC37 as the busybox executable was used standalone 😂.

Comment 5 Fedora Update System 2023-01-10 22:43:48 UTC
FEDORA-2023-9483e38187 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-9483e38187

Comment 6 Fedora Update System 2023-01-10 22:43:48 UTC
FEDORA-2023-742d00d24e has been submitted as an update to Fedora 36. https://bodhi.fedoraproject.org/updates/FEDORA-2023-742d00d24e

Comment 7 Fedora Update System 2023-01-11 02:41:21 UTC
FEDORA-2023-9483e38187 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-9483e38187`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-9483e38187

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-01-11 02:43:40 UTC
FEDORA-2023-742d00d24e has been pushed to the Fedora 36 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-742d00d24e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-742d00d24e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 9 Tom "spot" Callaway 2023-01-12 14:40:16 UTC
*** Bug 2160300 has been marked as a duplicate of this bug. ***

Comment 10 Anton Guda 2023-01-12 14:44:08 UTC
Seems all Ok. Propose to close this bug.

Comment 11 Fedora Update System 2023-01-19 06:10:23 UTC
FEDORA-2023-9483e38187 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2023-01-19 13:13:58 UTC
FEDORA-2023-742d00d24e has been pushed to the Fedora 36 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.