Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Description of problem:
Trying to import a content view into a disconnected Satellite fails with:
{"publication":["Invalid hyperlink - Object does not exist."]}
This was failing on a content view with multiple repos. We then created a content view for each of the individual repos (1 repository for each CV) and found it was failing for only 1 repository:
~~~
Red Hat Satellite 6.10 for RHEL 7 Server RPMs x86_64
~~~
From the disconnected Satellite we see these errors in the logs:
~~~
Apr 14 15:46:21 [satellite_host] pulpcore-api: pulp [9c12f387-80d4-47fb-8555-d99b439ee4d9]: django.request:WARNING: Bad Request: /pulp/api/v3/distributions/rpm/rpm/3c37becc-402d-49b3-9991-eb4e57369562/
Apr 14 15:46:21 [satellite_host] pulpcore-api: pulp [9c12f387-80d4-47fb-8555-d99b439ee4d9]: - - [14/Apr/2022:19:46:21 +0000] "PATH /pulp/api/v3/distributions/rpm/rpm/3c37becc-402d-49b3-9991-eb4e57369562/ HTTP/1.1" 400 62 "_" "OpenAPI-Generator/3.13.3/ruby"
~~~
Version-Release number of selected component (if applicable):
Satellite 6.10.2
How reproducible:
customer specific
Steps to Reproduce:
1.
2.
3.
Actual results:
Expected results:
Additional info:
Both connected/disconnected Satellite were installed at 6.9.2, then upgraded to 6.9.7 before upgrading to 6.10.1.1 then 6.10.2
Description of problem: Trying to import a content view into a disconnected Satellite fails with: {"publication":["Invalid hyperlink - Object does not exist."]} This was failing on a content view with multiple repos. We then created a content view for each of the individual repos (1 repository for each CV) and found it was failing for only 1 repository: ~~~ Red Hat Satellite 6.10 for RHEL 7 Server RPMs x86_64 ~~~ From the disconnected Satellite we see these errors in the logs: ~~~ Apr 14 15:46:21 [satellite_host] pulpcore-api: pulp [9c12f387-80d4-47fb-8555-d99b439ee4d9]: django.request:WARNING: Bad Request: /pulp/api/v3/distributions/rpm/rpm/3c37becc-402d-49b3-9991-eb4e57369562/ Apr 14 15:46:21 [satellite_host] pulpcore-api: pulp [9c12f387-80d4-47fb-8555-d99b439ee4d9]: - - [14/Apr/2022:19:46:21 +0000] "PATH /pulp/api/v3/distributions/rpm/rpm/3c37becc-402d-49b3-9991-eb4e57369562/ HTTP/1.1" 400 62 "_" "OpenAPI-Generator/3.13.3/ruby" ~~~ Version-Release number of selected component (if applicable): Satellite 6.10.2 How reproducible: customer specific Steps to Reproduce: 1. 2. 3. Actual results: Expected results: Additional info: Both connected/disconnected Satellite were installed at 6.9.2, then upgraded to 6.9.7 before upgrading to 6.10.1.1 then 6.10.2