Bug 207949 - lost keystrokes on virtual machine console
lost keystrokes on virtual machine console
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Berrange
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 11:21 EDT by Angus Thomas
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 11:49:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Angus Thomas 2006-09-25 11:21:37 EDT
Description of problem:
I have two X sessions running. Ctrl-Alt-F7 gives me the local gnome desktop.
Ctrl-Alt-F8 is another gnome desktop, exported from a woodcrest machine via
xdmcp. When switching between them, I find that the keyboard input to the
virt-manager's virtual machine console on the woodcrest breaks in various ways.
For example, it responds as if the Alt key was constantly pressed.

Version-Release number of selected component (if applicable):
virt-manager-0.2.2-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.Run two concurrent X sessions
2.Use keyboard shortcuts to switch between them
3.
  
Actual results:
Keyboard input to the virtual machine console is knackered

Expected results:
keyboard input should work as it does on a normal terminal, for example

Additional info:
Comment 1 Daniel Berrange 2006-09-25 11:27:01 EDT
We send VNC key events when getting  KeyPress/KeyRelease from X. So in this case
we're sending a KeyPress for the Alt & Ctrl keys, but since the final Fx key
switches to another local host console, the VNC server never gets sent the
KeyRelease events for Alt & Ctrl. So when switching back to the original host
console, the VNC server has Alt & Ctrl 'stuck' on. Looks like we need to 'reset'
key state when getting a LeaveNotify event
Comment 2 Daniel Berrange 2006-09-27 11:49:26 EDT
This issue is fixed in virt-manager-0.2.3-1.fc6 which will appear in rawhide
within the next day.

Note You need to log in before you can comment on or make changes to this bug.