Bug 207960 - rdesktop translucent with compiz enabled
Summary: rdesktop translucent with compiz enabled
Status: CLOSED DUPLICATE of bug 213502
Alias: None
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-09-25 15:41 UTC by das_deniz
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-08 19:51:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description das_deniz 2006-09-25 15:41:37 UTC
Description of problem:

when desktop-effects are enabled (compiz) the rdesktop - for non-default
colormaps (16 or 24 bit) - becomes translucent

Version-Release number of selected component (if applicable):

rdesktop-1.4.1-4
compiz-0.0.13-0.27.20060817git.fc6


How reproducible:

always

Steps to Reproduce:
1. System -> Preferences -> More Preferences -> Desktop Effects
2. Enable Desktop Effects
3. Run rdesktop -a16 or -a24 
4. Note translucent window... makes remote desktop very difficult to view.
  
Actual results:

entire remote desktop is presented translucent 

Expected results:

should be opaque.

Additional info:

Comment 1 Gawain Lynch 2006-10-20 03:41:36 UTC
This is fixed in rdesktop 1.5.  I guess this will be release as an update soon
after release?

Comment 2 lok 2006-11-01 02:52:43 UTC
I have just upgraded from FC 5 to FC6 and rdesktop has had similar issues to
those detailed above.  Installing rdesktop 1.5 has fixed these issues for me. 
An update d rdesktop package for FC6 would be much appreciated :)

Comment 3 Russell Harrison 2006-11-01 04:30:04 UTC
Confirmed that version 1.5.0 fixes the problem.

Downloaded the source rpm from the fedora repo.

Downloaded latest tarball from the rdesktop site.

changed the versions in the spec. . .

built without problem, upgraded cleanly, and fixed the issue!  This is why I
love open source.

Now I need to find some cute child to make puppy dog eyes at the maintainer till
they get it into the updates repo.

;-)

Comment 4 Behdad Esfahbod 2006-12-08 19:51:14 UTC

*** This bug has been marked as a duplicate of 213502 ***


Note You need to log in before you can comment on or make changes to this bug.