Bug 2079706 - suspend can not be resume back for ryzen 5000 system
Summary: suspend can not be resume back for ryzen 5000 system
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 35
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-28 06:59 UTC by bugzillllllaaaaaa
Modified: 2022-06-13 18:58 UTC (History)
27 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-03 18:27:37 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Output of dmesg on fresh boot after occurence of bug. (92.25 KB, text/plain)
2022-04-29 22:18 UTC, George Kokinis
no flags Details

Description bugzillllllaaaaaa 2022-04-28 06:59:18 UTC
Description of problem:suspension can not be resumed back need to be hard restart/reset.


Version-Release number of selected component (if applicable):started from the kernel :5.16.20 newest 5.17.4 still this problem persist.this peoblem is specific to the amd cpu 5500U series chipset.


How reproducible:go to suspend and it can't be resumed back.

Reference:https://ask.fedoraproject.org/t/suspend-does-not-recover-back-the-display/21585


Additional info:not required

Comment 1 Andy 2022-04-28 14:12:33 UTC
Can confirm this issue on a Dell Inspiron 5515 with AMD Ryzen 7 5500U, Radeon graphics, 16 GB RAM, 1 TB M.2 NVME SSD.

Using Fedora 35 with 5.16.18-200 kernel (works correctly) but upgrade to 5.16.20-200 kernel causes 100% repeatable failure.   Booting earlier (5.16.18) kernel causes suspend to work correctly again.

System appears to suspend normally, but will not wake up from suspend.   No option to reset, does not respond to power switch (even long press).

The only way to recover the system is to drain or disconnect the battery (which involves disassembling the laptop).

This effectively blocks Fedora 36 on this device.

Comment 2 bugzillllllaaaaaa 2022-04-28 19:57:09 UTC
I confirmed this on msi modern 15 amd 5500U 8gb ram 512gb ssd kernel before 5.16.18 is the last kernel that does not have suspension issue.
System suspended as intended but can't be resumed back to normal need to be hard reset/restart.

Comment 3 George Kokinis 2022-04-29 03:08:59 UTC
Can confirm this occurs on my system; see comment made on https://bodhi.fedoraproject.org/updates/FEDORA-2022-a86334434b .

Specifically, system reaches s2idle, then refuses to resume; power button is unresponsive. Fix requires disconnecting battery and discharging flea power.

System is a Dell Inspiron 5415, processor Ryzen 7 5700U with iGPU.

I cannot see anything in dmesg or kernel.log, bar "reached s2idle" followed by a fresh boot.

5.16.19-200 works for me, 5.16.20-200 and 5.17.4 both have this issue.

I had a similar issue previously, which was a bug in the amdgpu kernel module; however in that case, the power button was responsive and allowed me to shut the system down.

I will update with relevant logs in the morning when I've got the system working again.

Comment 4 Eric Brombaugh 2022-04-29 22:09:19 UTC
Confirmed on Lenovo IdeaPad 5 Pro 14" Touchscreen Laptop - AMD Ryzen 5 5600U:

* Initial install with Fedora 35 kernel 5.14.4-300 operated correctly.
* Subsequent upgrade to kernel 5.17.4-200 does not wake from sleep.
* Downgrading to original 5.14.4-300 kernel restores proper wake operation.

Comment 5 George Kokinis 2022-04-29 22:18:41 UTC
Created attachment 1876093 [details]
Output of dmesg on fresh boot after occurence of bug.

This is my dmesg on the boot immediately after the hard-reset occurring.

Comment 6 George Kokinis 2022-04-29 22:20:58 UTC
Comment on attachment 1876093 [details]
Output of dmesg on fresh boot after occurence of bug.

Note: this is during boot of kernel-5.16.19, a kernel that is working, so not necessarily any good for inspecting any form of this bug, but maybe good for comparison.

Comment 7 Hemanth 2022-04-30 05:46:10 UTC
I confirm this issue. 
My Laptop Specs:
Model: MSI modern 15 
CPU: Ryzen 5 5500U 
RAM: 8GB 
SSD: 512 GB
Graphics: Integrated

Comment 8 Rabin 2022-05-02 10:22:08 UTC
I have the same issue, but in my case, it is an Intel process.

```
System:
  Kernel: 5.17.4-200.fc35.x86_64 arch: x86_64 bits: 64 compiler: gcc
    v: 2.37-10.fc35 Console: pty pts/2 Distro: Fedora release 35 (Thirty Five)
Machine:
  Type: Laptop System: LENOVO product: 20EN001EUS v: ThinkPad P50
    serial: <filter>
  Mobo: LENOVO model: 20EN001EUS serial: <filter> UEFI: LENOVO
    v: N1EET94W (1.67 ) date: 12/10/2021
CPU:
  Info: quad core model: Intel Core i7-6820HQ bits: 64 type: MT MCP
    arch: Skylake-S rev: 3 cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  Speed (MHz): avg: 2638 high: 2999 min/max: 800/3600 cores: 1: 2999
    2: 2496 3: 2424 4: 2615 5: 2540 6: 2901 7: 2752 8: 2377 bogomips: 43198
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: NVIDIA GM107GLM [Quadro M2000M] vendor: Lenovo driver: nvidia
    v: 510.60.02 bus-ID: 01:00.0
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 1-8:2
  Display: server: X.Org v: 1.20.14 driver: X: loaded: nvidia
    gpu: nvidia,nvidia-nvswitch resolution: 1: 3840x2160~60Hz 2: 3440x1440~60Hz
  OpenGL: renderer: Quadro M2000M/PCIe/SSE2 v: 4.6.0 NVIDIA 510.60.02
    direct render: Yes
Swap:
  Alert: No swap data was found.
```

Comment 9 Anton Gonzalez 2022-05-03 00:30:17 UTC
(In reply to Andy from comment #1)
> Can confirm this issue on a Dell Inspiron 5515 with AMD Ryzen 7 5500U,
> Radeon graphics, 16 GB RAM, 1 TB M.2 NVME SSD.
> 
> Using Fedora 35 with 5.16.18-200 kernel (works correctly) but upgrade to
> 5.16.20-200 kernel causes 100% repeatable failure.   Booting earlier
> (5.16.18) kernel causes suspend to work correctly again.
> 
> System appears to suspend normally, but will not wake up from suspend.   No
> option to reset, does not respond to power switch (even long press).
> 
> The only way to recover the system is to drain or disconnect the battery
> (which involves disassembling the laptop).
> 
> This effectively blocks Fedora 36 on this device.

I'm experiencing the exact same issue. In my case, this is happening on an Acer Swift X equipped with an AMD Ryzen 7 5800u.

Comment 10 Justin M. Forbes 2022-05-03 12:43:56 UTC
You might give 5.17.5 a try, there were some fixes there.

Comment 11 George Kokinis 2022-05-03 14:26:35 UTC
Thanks Justin, will try on Friday once I've got this coursework in and give feedback.

Comment 12 Anton Gonzalez 2022-05-03 15:40:51 UTC
(In reply to Justin M. Forbes from comment #10)
> You might give 5.17.5 a try, there were some fixes there.

I can confirm that this fix works for me. I'm now on 5.17.5-300.fc36.x86_64 and suspend/wake works as it should.

Comment 13 Justin M. Forbes 2022-05-03 18:27:37 UTC
Thanks for the confirmation. Going to close this then as 5.17.5 is in stable now.

Comment 14 Eric Brombaugh 2022-05-04 04:09:46 UTC
Confirmed that kernel 5.17.5-200 fixed the issue on the Lenovo IdeaPad 5 Pro 14" Touchscreen Laptop - AMD Ryzen 5 5600U

Comment 15 bugzillllllaaaaaa 2022-05-05 16:21:15 UTC
Yes i can confirm issue resolved with 5.17.5 kernel update

Comment 16 ol.tkr 2022-05-06 19:34:10 UTC
i still have the issue with the 5.17.5 kernel ( but not sure if its the same cause, but still a freeze after opening up the laptop from sleep) . i just have reported the issue through the system "error center" to bugzilla,
https://bugzilla.redhat.com/show_bug.cgi?id=2070503

Comment 17 zzz 2022-05-07 21:05:16 UTC
5.17.5 kernel the same issue, ryzen 3900, gtx 1080, nv driver 510.68.02. Issue doesn't exists on 5.16.18-200

maj 07 22:53:50 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:50 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:50 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:53 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:53 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:53 darkspider systemd[1703]: Failed to start Application launched by gnome-session-binary.
maj 07 22:53:54 darkspider kernel: [drm:drm_new_set_master [drm]] *ERROR* [nvidia-drm] [GPU ID 0x00003100] Failed to grab modeset ownership

Comment 18 Eric Brombaugh 2022-05-19 13:26:15 UTC
I upgraded yesterday to kernel-5.17.7-300.fc36.x86_64 and the problem is back. Reverting to kernel-5.17.6-300.fc36.x86_64 appears to fix it.

Lenovo IdeaPad 5 Pro 14" Touchscreen Laptop - AMD Ryzen 5 5600U

Comment 19 Eric Brombaugh 2022-05-21 18:19:02 UTC
Kernel 5.17.8-300.fc36.x86_64 appears to have solved the problem.

Comment 20 zzz 2022-05-28 18:12:03 UTC
5.17.11-200 It looks like issue is solved. I need a bit more testing during next couple of days :-)

Comment 21 Andy 2022-06-13 18:58:44 UTC
Appears to be resolved in 5.17.13-200 on Dell Inspiron 5515 with AMD Ryzen 7 5500U, Radeon graphics, 16 GB RAM, 1 TB M.2 NVME SSD.


Note You need to log in before you can comment on or make changes to this bug.