Bug 2079892 - systemtap-client can't be installed with the latest dyninst
Summary: systemtap-client can't be installed with the latest dyninst
Keywords:
Status: CLOSED DUPLICATE of bug 2080874
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: systemtap
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: qe-baseos-tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-28 12:48 UTC by Takashi Kajinami
Modified: 2022-05-02 17:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-02 17:20:25 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-120368 0 None None None 2022-04-28 13:58:25 UTC

Description Takashi Kajinami 2022-04-28 12:48:46 UTC
Description of problem:

The updated version of dyninst ( dyninst-12.1.0-1.el9.x86_64.rpm ) was recently released.
After that, the current latest version of systemtap-client ( systemtap-client-4.6-11.el9.x86_64.rpm ) can't be installed because of the conflicts.
~~~
Error: 
 Problem: package systemtap-client-4.6-11.el9.x86_64 requires libcommon.so.11.0()(64bit), but none of the providers can be installed
  - package systemtap-client-4.6-11.el9.x86_64 requires libinstructionAPI.so.11.0()(64bit), but none of the providers can be installed
  - package systemtap-client-4.6-11.el9.x86_64 requires libparseAPI.so.11.0()(64bit), but none of the providers can be installed
  - package systemtap-client-4.6-11.el9.x86_64 requires libsymtabAPI.so.11.0()(64bit), but none of the providers can be installed
  - cannot install both dyninst-12.1.0-1.el9.x86_64 and dyninst-11.0.0-5.el9.x86_64
  - cannot install both dyninst-12.1.0-1.el9.x86_64 and dyninst-11.0.0-4.el9.x86_64
  - cannot install the best update candidate for package systemtap-client-4.6-11.el9.x86_64
  - cannot install the best update candidate for package dyninst-11.0.0-5.el9.x86_64
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use 
~~~


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install systemtap-client
 $ sudo dnf install systemtap-client -y

Actual results:
Installation succeeds

Expected results:
Installation fails because of conflict with the latest dyninst

Additional info:

Comment 1 Frank Ch. Eigler 2022-05-02 17:20:25 UTC

*** This bug has been marked as a duplicate of bug 2080874 ***


Note You need to log in before you can comment on or make changes to this bug.