Bug 2079895 - python3-qt5-5.15.0-3.el8.x86_64 can't be installed because of conflicting requirements.
Summary: python3-qt5-5.15.0-3.el8.x86_64 can't be installed because of conflicting req...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python-qt5
Version: CentOS Stream
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: RHEL CS Apps Subsystem QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2022-04-28 12:56 UTC by Takashi Kajinami
Modified: 2022-05-03 05:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-05-03 05:46:50 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-120399 0 None None None 2022-04-28 16:02:47 UTC

Description Takashi Kajinami 2022-04-28 12:56:46 UTC
Description of problem:

Installing the latest python3-qt5 packages ( 5.15.0-3.el8.x86_64 ) always fails because of the conflicting requirements.
Looking at the error, it seems the wrong version of .so file is required.
~~~
Error: 
 Problem 1: package python3-qt5-base-5.15.0-3.el8.x86_64 requires libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package python3-qt5-base-5.15.0-3.el8.x86_64 requires qt5-qtbase(x86-64) = 5.15.2, but none of the providers can be installed
  - cannot install both qt5-qtbase-5.15.3-1.el8.x86_64 and qt5-qtbase-5.15.2-4.el8.x86_64
  - cannot install both qt5-qtbase-5.15.3-1.el8.x86_64 and qt5-qtbase-5.15.2-2.el8.x86_64
  - cannot install both qt5-qtbase-5.15.3-1.el8.x86_64 and qt5-qtbase-5.15.2-3.el8.x86_64
  - cannot install the best update candidate for package qt5-qtbase-5.15.2-4.el8.x86_64
  - cannot install the best update candidate for package python3-qt5-base-5.15.0-3.el8.x86_64
 Problem 2: package python3-qt5-5.15.0-3.el8.x86_64 requires libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtdeclarative-5.15.3-1.el8.x86_64 and qt5-qtdeclarative-5.15.2-2.el8.x86_64
  - cannot install both qt5-qtdeclarative-5.15.3-1.el8.x86_64 and qt5-qtdeclarative-5.15.2-1.el8.x86_64
  - cannot install the best update candidate for package qt5-qtdeclarative-5.15.2-2.el8.x86_64
  - cannot install the best update candidate for package python3-qt5-5.15.0-3.el8.x86_64
 Problem 3: problem with installed package python3-qt5-base-5.15.0-3.el8.x86_64
  - package python3-qt5-base-5.15.0-3.el8.x86_64 requires libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package python3-qt5-base-5.15.0-3.el8.x86_64 requires qt5-qtbase(x86-64) = 5.15.2, but none of the providers can be installed
  - package qt5-qtbase-5.15.2-4.el8.x86_64 requires qt5-qtbase-common = 5.15.2-4.el8, but none of the providers can be installed
  - package qt5-qtbase-5.15.2-2.el8.x86_64 requires qt5-qtbase-common = 5.15.2-2.el8, but none of the providers can be installed
  - package qt5-qtbase-5.15.2-3.el8.x86_64 requires qt5-qtbase-common = 5.15.2-3.el8, but none of the providers can be installed
  - cannot install both qt5-qtbase-common-5.15.3-1.el8.noarch and qt5-qtbase-common-5.15.2-4.el8.noarch
  - cannot install both qt5-qtbase-common-5.15.3-1.el8.noarch and qt5-qtbase-common-5.15.2-2.el8.noarch
  - cannot install both qt5-qtbase-common-5.15.3-1.el8.noarch and qt5-qtbase-common-5.15.2-3.el8.noarch
  - cannot install the best update candidate for package qt5-qtbase-common-5.15.2-4.el8.noarch
 Problem 4: problem with installed package python3-qt5-5.15.0-3.el8.x86_64
  - package python3-qt5-5.15.0-3.el8.x86_64 requires libQt5Quick.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package qt5-qtdeclarative-5.15.2-2.el8.x86_64 requires libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package qt5-qtdeclarative-5.15.2-2.el8.x86_64 requires libQt5Widgets.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package qt5-qtdeclarative-5.15.2-1.el8.x86_64 requires libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - package qt5-qtdeclarative-5.15.2-1.el8.x86_64 requires libQt5Widgets.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
  - cannot install both qt5-qtbase-gui-5.15.3-1.el8.x86_64 and qt5-qtbase-gui-5.15.2-4.el8.x86_64
  - cannot install both qt5-qtbase-gui-5.15.3-1.el8.x86_64 and qt5-qtbase-gui-5.15.2-2.el8.x86_64
  - cannot install both qt5-qtbase-gui-5.15.3-1.el8.x86_64 and qt5-qtbase-gui-5.15.2-3.el8.x86_64
  - cannot install the best update candidate for package qt5-qtbase-gui-5.15.2-4.el8.x86_64
~~~


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install python3-qt5
 $ sudo dnf install python3-qt5

Actual results:
Installation succeeds

Expected results:
Installation fails because of conflicting requirements.

Additional info:

Comment 1 Takashi Kajinami 2022-05-02 08:55:58 UTC
It seems this was fixed by python3-qt5-5.15.0-3.0.1.el8.x86_64 .


Note You need to log in before you can comment on or make changes to this bug.