Bug 207997 - fontforge has issues with aiglx
fontforge has issues with aiglx
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontforge (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-09-25 14:50 EDT by Matthias Clasen
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-05 15:42:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Clasen 2006-09-25 14:50:45 EDT
or maybe it is motif apps having issues with aiglx.
fontforge comes up almost completely transparent.
running it with

XLIB_SKIP_ARGB_VISUALS=1 fontforge

works around the issue.
Comment 1 Matthias Clasen 2006-09-25 14:56:07 EDT
Moving this to fontforge, but unless fontforge explicitly selects a specific
visual, this is likely an openmotif/lesstif issue.
Comment 2 Kevin Fenzi 2006-09-25 15:56:50 EDT
Yeah, this looks like a fontforge issue... 
(fontforge doesn't use openmotif/lesstiff that I can see)

This appears to have been discussed in: 

http://www.nabble.com/Fontforge-and-Xgl-Compiz-t2196946.html

Not sure what, if anything, would be the solution. :( 
At least there is a workaround. 
Comment 3 Kevin Fenzi 2006-10-20 15:12:41 EDT
I just pushed out a new version of fontforge. 
They don't mention addressing this issue in the changelog that I can see, but 
the changelog is also very verbose, so I could have missed it. 

Can you test with the new version (20061019) and see if it still has the issue?
Comment 4 Roozbeh Pournader 2006-11-11 06:48:20 EST
Change status to needinfo from reporter.
Comment 5 Kevin Fenzi 2007-08-05 15:42:11 EDT
Looking at this now with the latest fontforge in F7, it looks like it's been fixed. 

I am going to go ahead and close this. 
Matthias: can you confirm it's fixed? If not, feel free to re-open this. 

Note You need to log in before you can comment on or make changes to this bug.